No ringback when oubound ringing

I have two systems, one where the ringing works on outbound and one where it doesn’t

I compared the settings and they look exactly the same, sip settings, advanced settings, custom conf files, codecs.

I tried forcing the r in asterisk trunk dial, and it works, but I’m concerned about the effects of this, and I shouldn’t have to, obviously.

onsite firewalls are the same, onsite routers are the same.

the only difference i can see off an ssh asterisk grab is “rtp probation passed” which is present on the working system, but not on the other…

any suggestions gratefully accepted, thanks guys


You say they are the same, but are they configured the same?

have you tried forwarding the RTP ports to the freepbx box?
have you checked Asterisk Sip settings in advanced? made sure internal and external IPs are correct?

Hi Miribis, thanks for taking the time, much appreciated,

yes, they are the same config,

cisco spa phones - register on private ip of pbx - pbx listens on public ip and registers to hosted trunk -

sonicwall firewall has two main rules - one for nat from pub to pri ip, and one to allow traffic for sip and rtp through from the trunk host,

trunk registers fine, and in exactly the same way,

not sure what you mean by forward the ports, but if i dont need to on one, why should i have to on the other :frowning:

yes the wans and lans are fine, and sip settings are identical,

any thoughts on rtp probation?


Probation passed - setting RTP source indicates that nothing is wrong at that point. Basically your system has sent OK to the handset, and telling it to acknowledge. If you’re not getting that on the other system then the 2 are not communicating properly. (which is obvious i know!)…

This to me would suggest that there is a Network configuration issue in the handset, or it’s struggling to deal with the NAT. Maybe the handset is setup for the other network still?? 1 setting wrong somewhere with regards to server or something?