No Ringback tone and audio delay on certain numbers

So - I hope ringback is the proper term. I have a generic Chinese brand WiFi SIP Phone. I really only call a few certain numbers. On two of those numbers, I see the following symptoms:

  1. The ‘ringing’ tone heard isn’t the traditional ‘ringing’ but sounds more like the BEEP you hear when a tv show or radio station censors a bad word. It’s the right length of time, but it’s a beep rather than a ring.
  2. Audio is muted for a few seconds both ways after the person I call picks up. I can see - when watching the logs - that the line is answered. But they can’t hear me, I can’t hear them, and the ringing stops. After a few seconds, we can all hear each other.

This again is on two specific numbers. Other numbers I’ve tried are fine.

Server is on a public IP. SIP Phone is on a WiFi on nat behind a router.

I should mention I also have a grandstream desk phone, this seems to work fine. That phone is wired.

Any suggestions on what to look for in my configuration on either the pbx or the phone? Codec issue? Something else?


So actually tried dialing one of the ‘problem’ numbers from my grandstream desk phone - same network, but Grandstream phone is wired.

Phone rang 2 times, then went to busy signal. Tried again, same thing.
Called from a cell phone - Went through fine, and party said I called twice, and when they answered, they heard a click and then a hang up.