No Ring Tone with Ring Groups


I have recently updated FreePBX to the latest module versions.

Now when you call an inbound route tide to a ring group, the caller does not hear a ring tone.

However if I redirect the inbound route to an extension the caller does hear a ring tone.

Has a bug been introduced into the Ring Group module ?



I’ve noticed this too for incoming callers. Are you using PJSIP or Chan_SIP? I’ve only noticed a problem with PJSIP but I figured out what was causing it. About three weeks ago a change was made to the ringgroups module. That change turned on Progress messages by default for every ring group. It was never an option in the previous version of the module and Asterisk’s default is not to send progress messages.

When you look at your ringgroups you’ll see “Send Progress” set to Yes. Set it to No and see if it fixes your problem. It did for me. If I switched the Trunk back to Chan_SIP it worked correctly even when leaving “Send Progress” set to Yes. I’m not sure why and I’m trying to figure out why at the moment.
EDIT: You need to have ringroups 13.0.18 module to edit the “Send Progress” setting. The issue was introduced in 13.0.17.


1 Like


Yes our trunks are using PJSIP.

And I have Ring Group Module 13.0.17 installed.

However when I check online there is no update for the Ring Module i.e. 13.0.18.

Has it been withdrawn or is it not available online ?



In Advanced Settings I changed “Set Module Admin to Edge mode” to Yes.

Ring Group 13.0.18 module update appeared.

In the Ring Group changing the “Send Progress” to No fixed the problem.



Fixed for me also! :slight_smile: