No ring tone heard by caller

Running FreePBX 3.2 beta distro on Dell Optiplex 755, 2.4GHz duo core, 8GB RAM, 2 X 250GB HDD in RAID 1.

Using IAX2 trunks (4) from, going through SonicWALL NSA240 router with port 4569 open and using NAT. Internet facing IP is static.

FreePBX is setup so each department has its own incoming number (reason for 4 trunks) and then is limited to those same incoming trunks on outgoing with the extension routing module. Each department has its own IVR and extension group, but all extensions can call one another internally by design.

Everything works great, except incoming caller does not hear any ring tones.

Opened trouble ticket with and they state that they do not support ringing to an IVR.

I have tried turning on fax detect, I have configured answer delay, I have tried MoH. No joy. So I have it configured to answer with the IVR almost immediately which catches callers off guard as they expect to hear ringing.

How do I configure FreePBX to get an incoming ring tone?

Appreciate any insight.

Here are the PEER details:

allow=ulaw&g729&gsm ;have tried this with just ulaw, no joy.

Look at your inbound route. The is an option “Signal RINGING”. Look at the help for that option.

Yes, I have had that checked. I am researching the “early information” posts that I have read about. Someone suggested creating a silent 500ms announcement and then setting that to answer, then to the IVR. Just not sure why the DID rings to an extension, but will not ring to an IVR. How does the carrier know?

Tried the “CALL FLOW CONTROL” with a silent announcement to answer the call. No joy. Really sounds like a carrier issue with, but they aren’t taking ownership or making suggestions.