No registration anymore, worked before

Hello FreePBX specialists,

My FreePBX worked perfect for a view months. I could registrated extentions indoor and outdoor on wifi
and phone network 4G (Netherlands).

Strainge enough i only can registrate my extension on my indoor pc (using zoiper) with pjsip. My mobile
phone is using chan sip and i tried the GSwave and Zoiper app on a samsung android phone. I didn’t change
my network or freepbx settings.

Till now i know that if i stop/start the intrusion detection under the menu Admin -> System Admin i can
sometimes registrate my extension on my mobile phone again. As long as the network on my phone
not change from example 4g to 3g or wifi to 4g, it works.

PBX Firmware:10.13.66-13
PBX Service Pack:
Asterisk Version: 13.11.2

Someone? Please Help! I’m stock on this problem

it sounds like your firewall is blocking the 4G network. There are two possible solutions:

  1. Whitelist your cell phone provider’s network.
  2. Start using Dynamic DNS and set the “hostname” in your phone to use a DDNS that you can whitelist (for finer grained control).

A bonus recommendation is to implement a VPN for your cell phone, but that’s something that is often outside the experience base for some people.

Thanks for you replay Dave!

I already use Dynamic DNS. Straing that the firewall blocks my 4g network. On 4G i can connect with a VPN to my
local lan.

Even if i put the freepbx machine in the DMZ of the firewall to test, it is not connecting anymore. Before it worked
perfect and in one time it stoped. Maybe some other solutions?

Where is the best location to whitelist my phones ip address?

Thanks in forward

Have you set up the integrated firewall and turned on the adaptive firewall?

All of these settings are in the Firewall Management section of the GUITAR.

The firewall has had many updates. It sounds like one of them tightened the controls and has caused something that used to work to now be blocked.