No recordings

I’ve done a fresh install of FreePBX 2.5 on Ubuntu Server 8.04 and I can not get calls to record. I’m able to make and receive call over an IAX2 trunk and voicemail is working. I’ve tried setting the recording option on the extension to record on demand and to record always, but never end up with any .wav files in /var/spool/asterisk/monitor (permisions for the dir are drwxrwxr-x 2 asterisk asterisk). I’ve also made sure that extension recording override is disabled in general settings. Any help would be greatly appreciated.



but unfortunately no solution up to now. If you find any, please let me know…

asterisk running as the user asterisk? or as somebody else? it NEEDS to be asterisk…

Perhaps a search would have helped.

Thanks for the replys.

mike577, I spent alot of time searching this and other sites because I’m new to this and I was trying to avoid the “Perhaps a search would have helped” comment. My symtoms were not the same as the thread you pointed out (“Record Always” wasn’t working).

My problem was the Extension Recording Override setting under General Settings. When you hover over the label you get:

“This will override the recording settings of all extensions/users. If enabled, the system will ignore all Record Always settings of a user and will not turn on recording. This does not effect On Demand recording controlled by the dial options ‘w’ and ‘W’ above. It does not effect other recording settings in modules such as Queues and Conferences. If you don’t use recordings, setting this is beneficial to system performance as it removes the check that is otherwise done on every single call.”

This is incorrect. The effect of this setting is actually the reverse. When set to “enabled”, $RECORDING_STATE is set to ENABLED which ALLOWS the “record always” setting on extensions and “disabled” ($RECORDING_STATE = DISABLED) overrides the extension settings.

Following the instructions, I set Extension Recording Override to disabled.

I saw a lot of posts where people were having problems with On Demand recording, so almost all of my testing was done using the “Record Always” setting. As soon as i switched Extension Recording Override back to Enabled (which is actually the default after install), recordings started working.