No Outgoing calls Freepbx 15


(Markus Roth) #21

And here is the log of an incoming call from a mobile: incoming call


#22

In settings for the trunk Telekom, try setting From User to +497136965460 and retest. If it still fails, please paste another log, because there may be more than one issue.


(Markus Roth) #23

Next log after changing From User: outgoing_2


(Markus Roth) #24

I found a config for the german telekom trunk here
Perhaps you can use this as a clue as to whether I still need to adjust something in my trunk configuration.


#25

Sorry, I missed the real problem.
In the Outbound Proxy setting for the trunk, you probably have something like
tel.t-online.de

But it should be
tel.t-online.de\;lr

Note backslash and semicolon.

If this breaks registration or incoming, please post your trunk settings (except for secret).

Also, on the incoming call, the From domain is ims.telekom.de but the To domain is telekom.de
So, if you still have trouble, try setting From Domain to one of these values.


#26

I had started my previous post without seeing the config at ip-phone-forum. That config does not appear to use an outbound proxy, but I guessed that the cause of no destination number in the URI is that you had set an outbound proxy.

Could you please post screenshots of your trunk settings? Were they based on another config that did require Outbound Proxy? Or, am I mistaken that you have one set?


#27

Another curiosity: On the call to Bechtle, the number format was 07132…, but in the next log (calling a mobile), the number format was +4917… do you expect both formats to be accepted? What did your old system send?


(Markus Roth) #28

Yes I accept both formats. If you call a number in the same region then the area code is also left out. I have to cover this case as well.
I have revised my trunk based on the instructions from the IP forum. I also entered the outbound proxy as you suggested. And see that it works! Both incoming and outgoing calls are now possible.
Tomorrow I will set the parameters of my trunk that are now set here, in case someone else has problems with them. But now I’m going to sleep first.
Thanks for your support!!


(Markus Roth) #29

Here are the settings for the trunk “Telekom”:






image


(Markus Roth) #30

the client URI and Server URI in the advanced PJSIP Settings must also be entered:
Client URI: sip:[email protected]
Server URI: sip:tel.t-online.de


(system) closed #31

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.