No outgoing call "Check the number" on Dahdi Channels

Hi, i’ve downloaded and installed latest asterisknow with Freepbx.
I configure (hope correctly) my Isdn Pci card:
[dahdi_hardware command]
pci:0000:01:0e.0 zaphfc+ 1397:2bd0 HFC-S ISDN BRI card

[dahdi_scan command]
[1]
active=yes
alarms=OK
description=HFC-S PCI A ISDN card 0 [TE]
name=ZTHFC1
manufacturer=Cologne Chips
devicetype=HFC-S PCI-A ISDN
location=PCI Bus 01 Slot 15
basechan=1
totchans=3
irq=0
type=digital-TE
syncsrc=0
lbo=0 db (CSU)/0-133 feet (DSX-1)
coding_opts=AMI
framing_opts=CCS
coding=AMI
framing=CCS

[dahdi-channels.conf]
; Span 1: ZTHFC1 "HFC-S PCI A ISDN card 0 [TE] " (MASTER) AMI/CCS
group=0,11
context=from_dahdi
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 1-2
context = default
group = 63

[chan_dahdi.conf]
[channels]
language=it
busydetect=yes
busycount=10
usecallerid=yes
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
echotraining=no
immediate=no
faxdetect=yes
rxgain=0.0
txgain=0.0

In asterisk:
[dahdi show status]
Description Alarms IRQ bpviol CRC Fra Codi Options LBO
HFC-S PCI A ISDN card 0 [TE] OK 0 0 0 CCS AMI 0 db (CSU)/0-133 feet (DSX-1)

[dahdi show channels]
Chan Extens Context Lang MOH Interpret Blocked State Descr.
pseudo default default In Service
1 from-dahdi it default In Service
2 from-dahdi it default In Service

when i try to call in asterisk -vvvvvvvv i see this message:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] ResetCDR(“SIP/101-0000000a”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/101-0000000a”, “”) in new stack
– Executing [[email protected]:3] Progress(“SIP/101-0000000a”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/101-0000000a”, “1”) in new stack
> 0xb5c2c988 – Probation passed - setting RTP source address to 192.168.1.31:16480
– Executing [[email protected]:5] Progress(“SIP/101-0000000a”, “”) in new stack
– Executing [[email protected]:6] Playback(“SIP/101-0000000a”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
– <SIP/101-0000000a> Playing ‘silence/1.slin’ (language ‘it’)
– <SIP/101-0000000a> Playing ‘cannot-complete-as-dialed.gsm’ (language ‘it’)
– <SIP/101-0000000a> Playing ‘check-number-dial-again.gsm’ (language ‘it’)
– Executing [[email protected]:7] Wait(“SIP/101-0000000a”, “1”) in new stack
– Executing [[email protected]:8] Congestion(“SIP/101-0000000a”, “20”) in new stack
[2014-01-02 13:20:46] WARNING[2084][C-0000000b]: channel.c:4816 ast_prod: Prodding channel ‘SIP/101-0000000a’ failed
== Spawn extension (from-internal, 0426xxxxxx, 8) exited non-zero on ‘SIP/101-0000000a’
– Executing [[email protected]:1] Hangup(“SIP/101-0000000a”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/101-0000000a’

Incoming call are all ok but i can make outgoing call.
What’s wrong?

Eureka!
I forget to define Dial Patterns on Outbound routes.

Well done. Not sure why you need to use AsteriskNOW with FreePBX but, since I have a running system with the same ISDN BRI PCI Card (HFC-S Cologne Chip based) and since some very good effort has been done by FreePBX developers (on DAHDI Configuration Module in particular) to let this card be managed via FreePBX (and so on FreePBX Distro) I ask: why not trying the FreePBX Distro (Track 4 or Track 5) directly? the benefits worth a try…