No outbound calls due incorrect INVITE format

For about a week, possibly since some updates, we have been unable to make outbound calls (message says “the number you have dialed is not in service…”). Incoming and internal calls work fine. Our SIP provider tells me that the From field is incorrectly formatted. Here was a good invite from a week ago from their sip logs (I have substituted the number dialled, 01234567890 is our CID):

INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP OURIPADDRESS:5060;rport;branch=z9hG4bKPjcfbfb7b9-935a-40a2-9d53-030ddd750f51
From: sip:[email protected];tag=b336390a-761c-4b0f-bf77-e6eaa54fe013

and here is what is happening now:

INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP OURIPADDRESS:5060;rport;branch=z9hG4bKPj50fc98b6-28b4-40a3-9991-6aa0c344f887
From: sip:[email protected];tag=3654b153-c4da-4f26-b108-8fb74b23cf93

where 10 is the extension that initiated the call and is our FreePBX locally.

The main Asterisk log just says:
[2022-03-10 10:12:47] VERBOSE[29476][C-00000003] app_dial.c: Called PJSIP/[email protected]
[2022-03-10 10:12:47] VERBOSE[29476][C-00000003] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)

Any help tracking down the issue and getting our CID back into the Invite would be much appreciated.

FreePBX 15.0.23, Asterisk 13.38.3


There was a change published to the core module in edge which is now reverted. Upgrading core should resolve, but you can also correctly set Cid per extension or outbound route.

I’ve had a number of sites not routing inbound calls correctly after recent updates. Had to open up the modules involved and just apply again, even though no changes were made. I’ve had this happen with inbound routes and ring groups.

I know this isn’t the same as what you are reporting but perhaps try opening up your outbound routes, and simply save and apply them and see what happens?

Many thanks. Module Admin says Core is at 15.0.17 (Stable). Do I need to upgrade/overwrite, and if so could you tell me how/what command to use?

Try upgrading to 15.0.19 pls

fwconsole ma downloadinstall core --tag 15.0.19
fwconsole r

Upgrading to 15.0.19 fixed it, thank you so much.
PS Just fyi adding a CID to the extension also worked as a work-around, but having the CID in the Trunk made no difference.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.