No outbound audio when calls routed to a queue

Please be kind, the first time I had used asterisk/freepbx was less than a week ago.

I am running FreePBX distro 1.1008.210.58-1 and trying to route pstn calls through a Panasonic TDA 30 with a SIP GW card installed to asterisk.

I have set up a trunk on FreePBX and can connect the two without problems, make calls receive calls etc.

But when I route the calls via an inbound route to a queue, in about 50% of the calls once the queued call is answered there is no audio being received on the panasonic side. (I have also tried this with an extension setup in FreePBX and dialling a virtual extension that forwards to the queue)

They are both on the same private network (so should be no nat issues)

I have added in…

qualify=no
nat=no
directmedia=no

Tired Reinvite Behavior to yes/no/update

These have not changed the problem

In the queue I have tried, using default MOH, ringing only.
On the incoming route I have tried signal ringing and a ring delay.

The sip debug on a good and bad call looks the same, as far as I can tell.

DTMF does get sent, it’s not inband so might not mean anything.

RTP debug shows that packets are being ‘got’ and ‘sent’ to the other exchange, the panasonics RTP port (or ip) doesn’t change once the call is answered.

At the moment I have this queue setup and working using a linksys PAP2 that connects to the panasonic instead of the SIP GW card, but the call quality is awful [analog>panasonic (digital)>analog>SIP>Asterisk].

I hope someone can point me in the right direction or shed some light on this.

Thanks…