No matching peer for [phone number] from [gsm gateway local ip address]


(Adamm) #1

We have Yeastar TG100 GSM Gateway. Everything worked well till today and i don’t know why that has changed. PJSIP Trunk has been created in order to GSM gateway and FreePBX communicate properly. We can make outbound calls but incoming calls fails, and this is what asterisk debug says:

No matching peer for [phone number] from [gsm gateway local ip address]

The only solution is to set both settings

Allow Anonymous Inbound SIP Calls and Allow SIP Guests

to Yes, and that is only way we can have inbound calls, but i don’t want to do that because of potential security risks. Also, i didn’t touch that settings before and incoming calls worked perfectly fine, so i don’t see the reason to set it up now. If i change Allow SIP Guests to Yes i hear the message The number you have dialed is not in service

One more important information - we have SIP trunk that works perfectly well, thank to God, both incoming and outgoing calls, nothing has changed there.

I’m desperate, so please help!

Current PBX Version: 15.0.16.77
Current System Version: 12.7.8-2008-1.sng7


#2

For the pjsip trunk, set Match (Permit) to the local IP address of the gateway.

If no luck, at the Asterisk command prompt type
pjsip set logger on
make a failing incoming test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.


(Adamm) #3

@Stewart1 Thank you sooo much! :blush: According to your suggestion i’ve found out that UDP port settings on FreePBX and GSM gateway do not match:
https://pastebin.freepbx.org/view/raw/282b2404

so i changed port to 5180 on my Yeastar gateway and it magically worked :slight_smile:
I’m always confused with SIP and PJSIP ports and those kind of settings so it made me a huge problem today, but doesn’t matter anymore, i’m glad it’s finally working!

Thanks again!


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.