No matching endpoint found

I am in the process of setting up a freepbx server to join NRENum. I started by experimenting in a lab environment where I installed two freepbx servers each with a single network interface. The first server has IP 193.1.2.3 and the second server has IP 192.168.1.252. On both servers I have created an ENUM tunnel and a default outbound route with
a dial match pattern X. On server one I have created extension 2252 and on server 2 extension 2059. When I dial from server one 9613763630 the server does a DNS NAPTR lookup and route the call to the second freepbx server however on server 2 I get No matching endpoint found

logs from server 1 where the call is initiated from extension 2252:

– Launched AGI Script /var/lib/asterisk/agi-bin/enumlookup.agi
– enumlookup.agi: Looking up 9613763630 on e164.org via dns_get_record
– enumlookup.agi: Looking up 9613763630 on e164.arpa via dns_get_record
– enumlookup.agi: Looking up 9613763630 on e164.info via dns_get_record
– enumlookup.agi: Looking up 9613763630 on nrenum.net via dns_get_record
– enumlookup.agi: Setting DIALARR to sip/[email protected]%
– <PJSIP/2252-00000049>AGI Script enumlookup.agi completed, returning 0
– Executing [[email protected]:14] ExecIf(“PJSIP/2252-00000049”, “1?Set(CONNECTEDLINE(num,i)=9613763630)”) in new stack
– Executing [[email protected]:15] ExecIf(“PJSIP/2252-00000049”, “1?Set(CONNECTEDLINE(name,i)=CID:2252)”) in new stack
– Executing [[email protected]:16] GotoIf(“PJSIP/2252-00000049”, “0?s-,1”) in new stack
– Executing [[email protected]:17] ExecIf(“PJSIP/2252-00000049”, “1?Set(DIAL_TRUNK_OPTIONS=M(setmusic^none)Ttr)”) in new stack
– Executing [[email protected]:18] ExecIf(“PJSIP/2252-00000049”, “0?Set(DIAL_TRUNK_OPTIONS=M(confirm)M(setmusic^none)Ttr)”) in new stack
– Executing [[email protected]:19] Set(“PJSIP/2252-00000049”, “TRYDIAL=sip/[email protected]”) in new stack
– Executing [[email protected]:20] Set(“PJSIP/2252-00000049”, “DIALARR=”) in new stack
– Executing [[email protected]:21] Dial(“PJSIP/2252-00000049”, “sip/[email protected],300,M(setmusic^none)Ttr”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called sip/[email protected]
[2016-09-26 15:33:16] NOTICE[1960][C-00000044]: chan_sip.c:23827 handle_response_invite: Failed to authenticate on INVITE to ‘sip:[email protected]:5160;tag=as75b8ce9b’
– SIP/192.168.1.252-0000002f is circuit-busy

Logs from server 2:

[2016-09-26 15:44:42] NOTICE[1870]: res_pjsip/pjsip_distributor.c:525 log_failed_request: Request ‘INVITE’ from ‘sip:[email protected]’ failed for ‘193.1.2.3:5160’ (callid: [email protected]:5160) - No matching endpoint found
freepbx-vm*CLI>

I appreciate any help

Regards,

Ramzi

Confused! Are there pjsip and chan_sip are used?

No, I am using only pjsip. On each server I have 1 extension of type pjsip.

I noticed that the port that is being used is 5160 which is for CHAN_SIP while the CHAN_PJSIP should be 5060. Could that be the problem and how can I change the port.

Regards,

You can change SIP driver bind ports in Settings, Asterisk SIP Settings. Restart Asterisk after the change with ‘fwconsole restart’