FreePBX | Register | Issues | Wiki | Portal | Support

No Matching Endpoint - Best way to fix?


(Jeff) #1

[2019-03-09 07:14:45] NOTICE[20691] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from 'failed for ‘54.244.51.0:5060’ (callid: 1f07bd18b8d8d36ee1a211ec4de10aa5@0.0.0.0) - No matching endpoint found

So I understand this is a SIP vs.PJSIP issue but what is the best way to fix this?

I am using a Polycom VVX500 and a Twillio Trunk.

My trunk is configured as sip and the extension as pjsip.

If I change my phone to sip it no longer registers.

When I allow Allow Anonymous Inbound SIP Calls the inbound works but I noticed in the logs a lot of attempts form unknown IPs so I don’t want to keep this on.

Thank you in advance.


(Tom Ray) #2

You need to point the Origination URI at Twilio with the proper port for Chan_SIP which is 5160. That will stop it from sending calls to port 5060 which PJSIP listens on.


(Jeff) #3

The only way I see to do this at Twillio is to enable Secure Trunking “When Secure Trunking is enabled, TLS must be used to encrypt SIP messages on port 5061, and SRTP must be used to encrypt the media packets. Any non-encrypted calls will be rejected.” but when I do this everything breaks.


(Tom Ray) #4

You aren’t reading what I said or what is at Twilio. I said 5160 not 5061. As well you log into Twilio then

  • Go to Elastic SIP Trunks
  • Click on the Origination Option
  • Click on the DID you need to edit
  • Change the port from 5060 to 5160
  • Save it

Done.


(Jeff) #5

I truly apologize Blaze Studios but I do not see the availability to change the port in my Twilio account in the Elastic SIP Trunks area. I know you said click on the DID but I do not see this.


#6

I don’t have any Twilio DIDs, but I would assume that there is a place where you enter
sip:11.22.33.44
or
sip:mypbx.mycompany.com

Have you tried changing that to
sip:11.22.33.44:5160
or
sip:mypbx.mycompany.com:5160
?

If it didn’t work, provide details (error message when entered, change had no effect, FreePBX gave a different error, etc.)

BTW, given that Twilio sends calls from multiple IP addresses (therefore requiring multiple chan_sip trunks), why didn’t you just use a pjsip trunk for Twilio, where you can simply list the addresses in the match field?


(Jeff) #7

I want to thank everyone for their help.

I tried putting the port :5160 at the end of the string but it still didn’t work so I took your advice and just created a new pjsip trunk and everything is working now.

Thank you everyone once again for the help.


#8

I’m glad to hear that you got it working, but could you please post what happened when you added the :5160? In particular, were you then getting an error from chan_sip, or was the port specification simply ignored.

The reason I’m asking is that some users choose a non-standard SIP port, either as a ‘security by obscurity’ measure, or to get around a SIP ALG issue imposed by their ISP or the user’s ISP.


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.