No incoming calls

Hello,

A week or so ago, I was helped very well by this community with a problem with my existing setup, I was running Trixbox, and was advised that freePBX is the better option.

I looked into it, took the advice, and I’m moving our offices system over to freePBX.

I’ve set up a test system, and I’ve copied most settings across,
I can make internal calls fine, I can make outgoing calls fine - but incoming calls are not working.

I’ve posted some code from below, and can post more if needed.

I thought about Paid Support, but unfortunately my directors aren’t prepared to foot any further costs towards our telephony system.


[Dec 22 12:26:00] VERBOSE[19137] pbx_spool.c: -- Attempting call on Local/[email protected] for application Noop(Time Conditions Override Maintenance Script) (Retry 1)
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: -- Executing [[email protected]:1] Set("Local/[email protected];2", "TCMAINT=RETURN") in new stack
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: -- Executing [[email protected]:2] GosubIf("Local/[email protected];2", "0?timeconditions,1,1") in new stack
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: -- Executing [[email protected]:3] GosubIf("Local/[email protected];2", "0?timeconditions,2,1") in new stack
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: -- Executing [[email protected]:4] System("Local/[email protected];2", "/var/lib/asterisk/bin/schedtc.php 60 /var/spool/asterisk/outgoing 0") in new stack
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: -- Executing [[email protected]:5] Hangup("Local/[email protected];2", "") in new stack
[Dec 22 12:26:00] VERBOSE[19138] pbx.c: == Spawn extension (tc-maint, s, 5) exited non-zero on 'Local/[email protected];2'
[Dec 22 12:26:00] NOTICE[19137] pbx_spool.c: Call failed to go through, reason (1) Hangup
[Dec 22 12:26:00] VERBOSE[19141] manager.c: == Manager 'admin' logged on from 127.0.0.1
[Dec 22 12:26:01] VERBOSE[19143] manager.c: == Manager 'admin' logged on from 127.0.0.1
[Dec 22 12:26:01] VERBOSE[19146] manager.c: == Manager 'admin' logged on from 127.0.0.1

A couple of Questions:

What type trunks are you using?
How have you setup inbound routes?

BF

Thanks for the reply, really appreciate it.

I’m using SIP trunks, they’re set up as below;

Outgoing

disallow=all
allow=alaw
host=iax.trunk.gradwell.com
type=peer
username=xxxxx
secret=xxxxx
requirecalltoken=no


xxxx is replaced with real values.
Incoming

context=from-pstn
type=user
secret=xxxx
requirecalltoken=no

Again, xxxx is a real value.

In regards to Inbound Routes, I’ve really been struggling with it - but what I’m trying to achieve is the following;

Customer calls, They get placed into a queue, which rings all in a ring group, if all operators are busy, they stay in queue, being told queue position.

I’ve got the route set up as below;

description: company name
did: company phone number

All other values left blank/default, apart from;

Destination: ringgroup all phones <800>

Obviously the destination isn’t providing me with the queue I’m after, but I want to at least get calls coming through before I start the queue.

I really do appreciate the help, it’s giving me a lot of information about linux and asterisk, and It’s something I’m going to continue learning, even once I’ve got this situation sorted - I’ll definitely be plowing any knowledge I gain back into the community.

I don’t think requirecalltoken is a peer level variable, it is general level and needs to go in iax settings module.

If you turn off verbosity (core set verbose 0) and debug (core set debug 0) and turn on IAX debugging (iax2 set debug on) and make an incoming call you will probably see an error “no authority found”

You need a username in the inbound settings and also set the trunk name the same as the provider user name (case sensitive)

One other thing you might want to check is in what the format format the DID is being received.

The Incoming DID setting must exactly match the received DID. But in looking at your logs, I don’t see where the DID is actually hitting the box.

In any case, once you’ve resolved the issues which SkyKing referenced, leave the DID box blank, then any call hitting the box will go to the destination defined for that inbound route. Once you get that working, you should be able to build on that.

BF

I’ve got a feeling I know what’s happening.
Having tried all the above, my logs look a lot fuller;

If I make an outgoing call, I see it on logs.
If I make an internal call, I see it on logs.

I don’t see a thing from an incoming call.

BUT, I’ve currently got two systems on my trunk (directors don’t want me to turn existing phones off until I’ve got the test box functioning well)

If I make a call to the company, it’s coming through to all the phones that are on the trixbox.

Would it be that the trixbox is recieving the call, and not allowing it to go through to my secondary setup which is freePBX.

I can’t imagine calling my DID would ring phones on BOTH boxes?

Further established that it should still hit the box.
I feel it’s maybe a trunk setting, settings are still as above.

I’ve even added the box into the DMZ and removed all firewall settings, nothing.
Still no incoming.

In the general settings, enable the Allow Anonymous Inbound calls.

In the inbound routes, create a catchall inbound route (i.e. one with no DID and no CID listed). Route it to something unique so that if you reach it, you’ll know you’ve reached it. I like to route to the Time of Day Feature code.

Then look at your call logs and the logs of your VOIP provider, and listen for the time lady. If you reach it, the you know the problem is an inbound route issue.

It’s fine to leave allow anonymous inbound routes, but you’ll eventually want to change the catchall route to “terminate call, hang-up.”

Also, I think you have a trunk configuration problem. You stated that you are using SIP trunks, and yet you are using IAX parameters and your hostname as “iax” in it. If you want to use IAX Trunks, then use IAX Trunks. If you want to use SIP trunks, then use SIP hosts.