No incoming calls using Gizmo as a provider

I am new with Asterisk/FreePBX and Voip as whole, so please bear with me.

This is my first post in this site as I am unable to find an aswers anywhere to my problem. Nor a hint.

I have sucessfully installed Asterisk 1.4.20 with FreePBX 2.4

I created several extensions and am able to complete calls between extensions wiht no issues.

In using the Gizmo as a provided I created a trunk and am successfull at making outbound calls from any extension,

My problem is with incoming calls.

When an incoming call is placed I get a busy signal.

Here are ny Trunk settings:

OUTBOUND

Trunk Name:
proxy01.sipphone.com

Peer Details:
type=peer
disallow=all
allow=ulaw&ilbc
dtmfmode=rfc2833
host=proxy01.sipphone.com
fromdomain=proxy01.sipphone.com
insecure=very
qualify=yes
fromuser=xxxxx
authuser=xxxxx
username=xxxxx
secret=xxxxxx
canreinvite=no

INBOUND

User Context:
FromGizmo

User Details:
type=user
context=from-trunk
disallow=all
allow=ulaw&ilbc
dtmfmode=rfc2833
host=proxy01.sipphone.com
insecure=very
username=xxxxx
secret=xxxxx
canreinvite=no

Register String:
xxuserxx:[email protected]

INCOMING ROUTE
any DID/any CID

Goes to a specific extension.

In reviewing the CLI output when a call is placed to my Gizmo incoming number I see the following:

-- Executing [[email protected]:1] GotoIf("SIP/rottensores-09801958", "0?from-trunk||1") in new stack
-- Executing [[email protected]:2] Set("SIP/rottensores-09801958", "TIMEOUT(absolute)=15") in new stack
-- Channel will hangup at 2008-07-13 03:22:53 UTC.
-- Executing [[email protected]:3] Answer("SIP/rottensores-09801958", "") in new stack
-- Executing [[email protected]:4] Wait("SIP/rottensores-09801958", "2") in new stack
-- Executing [[email protected]:5] Playback("SIP/rottensores-09801958", "ss-noservice") in new stack
-- <SIP/rottensores-09801958> Playing 'ss-noservice' (language 'en')
-- Executing [[email protected]:6] PlayTones("SIP/rottensores-09801958", "congestion") in new stack

== Spawn extension (from-sip-external, s, 6) exited non-zero on ‘SIP/rottensores-09801958’
– Executing [[email protected]:1] NoOp(“SIP/rottensores-09801958”, “Hangup”) in new stack
– Executing [[email protected]:2] Set(“SIP/rottensores-09801958”, “DID=s”) in new stack
– Executing [[email protected]:3] Goto(“SIP/rottensores-09801958”, “s|1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/rottensores-09801958”, “0?from-trunk|s|1”) in new stack
– Executing [[email protected]:2] Set(“SIP/rottensores-09801958”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2008-07-13 03:23:00 UTC.
– Executing [[email protected]:3] Answer(“SIP/rottensores-09801958”, “”) in new stack
== Spawn extension (from-sip-external, s, 3) exited non-zero on ‘SIP/rottensores-09801958’

Unfortunatelly I am unable to see what is wrong or how to fix it.

Any help will be appreciated.

http://www.freepbx.org/support/documentation/howtos/howto-setting-up-voip-provider-trunks/gizmo5

Thank you.

Although the the setup page seems to only provide outgoing setup information, I tried it and did not resolved my inbound call problem.

Now I get a Gizmo message tellimg me that the user is offline, so I placed the User details back even though the above setup says it not used.

Since the CLI output pointed me to the from-sip-external context I decided to play with it.

After several attempts I changed the Context to be very simple, where it only has the following

exten => _.,1,Wait(1)
exten => _.,2,Goto(from-pstn,s,1)

I also changed the Inbound context to default instead of from-trunk.

By doing so I was able to complete incoming calls.

This resolves my problem for now.