FreePBX | Register | Issues | Wiki | Portal | Support

No incoming call's after module update


(Maxim P.) #1

No incoming calls after updating modules. Outgoing work.
Current PBX Version: 14.0.5.2
Current System Version: 12.7.4-1803-1.sng7

Installing the latest version of FreePBXDistro - no incoming with identical config. Installing the old version 10.13.66 without updates - it works. After updates - no incoming calls.

List of modules:

Module Name Current Version New Version
Preserve Accountcode 13.0.2 13.0.2.2
Announcements 13.0.7.1 13.0.7.3
Backup & Restore 14.0.3.15 14.0.10.1
Blacklist 13.0.14.8 14.0.1
Bulk Handler 13.0.14.4 13.0.14.7
Calendar 14.0.2.2 14.0.2.6
Callback 13.0.5.2 13.0.5.3
Call Forward 14.0.1.2 14.0.1.3
Call Recording 13.0.11.5 14.0.5
CDR Reports 14.0.5.10 14.0.5.14
Call Event Logging 14.0.2.3 14.0.2.8
Certificate Manager 13.0.37 14.0.3.1
CallerID Lookup 14.0.1.5 14.0.1.7
Conferences 13.0.23.9 13.0.23.12
Contact Manager 14.0.3.4 14.0.4.10
Core 14.0.5.11 14.0.18.37
DAHDi Config 14.0.1.1 14.0.1.3
System Dashboard 14.0.3.3 14.0.4.1
Digium Phones Config 13.0.7.3 13.0.7.4
DISA 13.0.6.1 13.0.6.6
Fax Configuration 14.0.2.2 14.0.2.6
Follow Me 14.0.1.16 14.0.1.20
System Firewall 13.0.49.2 13.0.57.1
Asterisk IAX Settings 14.0.1.3 14.0.1.4
Info Services 13.0.1.2 13.0.1.3
Online Support 2.11.0.7 13.0.1
IVR 13.0.27.6 14.0.4
Languages 13.0.6 14.0.1.2
Asterisk Logfiles 13.0.10.4 13.0.10.5
Music on Hold 13.0.22.3 13.0.22.4
Paging and Intercom 13.0.26.3 14.0.6
Parking Lot 13.0.19.7 13.0.19.8
PIN Sets 13.0.8 13.0.10
Process Management 13.0.4.2 13.0.5.1
Presence State 14.0.1.5 14.0.1.7
Queues 14.0.2.11 14.0.2.22
Ring Groups 14.0.1.4 14.0.1.5
Asterisk SIP Settings 14.0.26.7 14.0.27.5
SMS 14.0.4.3 14.0.4.6
Sound Languages 14.0.4.2 14.0.5
CID Superfecta 14.0.4 14.0.7
System Admin 14.0.11.2 14.0.22
Time Conditions 14.0.2.12 14.0.2.15
User Control Panel 14.0.2.1 14.0.3.1
User Management 14.0.3.37 14.0.3.44
Voicemail 14.0.1.17 14.0.4.1

(Maxim P.) #2

All my phones use PJSIP and port 5060, but the trunk CHAN_SIP (according to the provider settings) also uses port 5060. In the old version of the FreePBX modules, everything works, after the update an error appears:

[2018-12-06 19:09:57] NOTICE[28255]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘OPTIONS’ from ‘sip:ping@nwtelecom.ru’ failed for ‘10.200.191.140:5060’ (callid: ac5e27f26a38b3284a9024178e5e8e64000ena2@10.200.191.140) - No matching endpoint found
[2018-12-06 19:10:57] NOTICE[43695]: res_pjsip/pjsip_distributor.c:649 log_failed_request: Request ‘OPTIONS’ from ‘sip:ping@nwtelecom.ru’ failed for ‘10.200.191.140:5060’ (callid: ac5e27f26a38b3284a9024178e5e8e64000e7b2@10.200.191.140) - No matching endpoint found

Trunk config:
Outgoing
host=10.200.191.140
type=peer
Inkoming - nothing


(Andrew Nagy) #3

There is no way in the world you could have had pjsip on 5060 and chan sip on 5060. Its never worked like that. Ever.


(Maxim P.) #4

in config, CHAN_SIP uses 5160/5161, PJSIP - 5060/5061
but provider use CHAN_SIP on port 5060

as I understand it:
TRUNK from the provider’s side, it works on CHAN_SIP, from my side - PJSIP
Or how?

I tried to completely disable PJSIP immediately after installation and use only CHAN_SIP, but after updating the modules I get the same error. Probably from the provider changed the settings? And they now also use PJSIP?


(Tom Ray) #5

Unless you are doing a SIP REGISTER with the provider, they have no idea what IP or PORT your PBX is listening on unless they’ve been told by you where to send calls. If you’ve only given them an IP without a port they will assume 5060.

Basically providers send calls where the user says send calls to, same with OPTIONS, etc. That is done one of two ways. 1) You REGISTER to them which provides them that information or 2) You setup your account with them to route requests (Calls, etc) straight to an IP:Port destination.