No incoming call from trunk


(Estados Unidos) #1

Hi guys, I’m having a problem with my trunk, outgoing calls work, but incoming calls don’t, this is my trunk configuration:

DETATIS PEER
host=172.31.21.1
type=peer
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw
qualify=yes
insecure=port,invite

DETAIS USER:
host=172.31.21.1
type=peer
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw
qualify=yes
insecure=port,invite

some help please


(Dave Burgess) #2

You’re using Chan-SIP, so that’s not cool. You probably need to switch this to PJ-SIP.

Unless your ITSP is in your local network, I don’t think those settings won’t work. You can verify this by checking your /var/log/asterisk/full logs to see what’s happening with your incoming calls.

If you are going to keep using Chan-SIP, you should set this up as a single config in the PEER settings and use a “type=friend” so that the settings are shared with your incoming and outgoing.


(United Kingdom) #3

did you add the register for the inbound calls and then added the number in inbound on connectivity?


(Estados Unidos) #4

Cynjun is correct, thank’s


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.