No Incoming audio on Outgoing Calls

I have a Raspberry Pi running FreePBX. My only problem is on outgoing calls I can’t hear the other party.

This is always, without fail, a NAT problem.

I’d say almost always. CODEC mismatches can do this too, but that is an edge case and easy to eliminate. To remove this case, change all of your CODEC lists to just use ALAW or ULAW (depending on your locale[All places or 'mUrica]).

If you are absolutely certain that all of your NAT configuration and firewall settings are correct (including disabling SIP-ALG, if in use).and you are still having problems, we’ll need SIP debugs and log excerpts to help you debug this.

Having said that, I’m with Rob - this is almost certainly a NAT problem.