No inbound or outbound audio

What have I missed?

Had a router failure. Replaces old cisco router with Edgerouter 4. Router is up and running, can place calls and receive incoming call but I have no audio either way.

I have port forward 10000-20000 from WAN to pbx ip ports 10000-20000 UDP.

Can make calls between inter-office over IAX with no issues.


I would start with

rtp set debug on

in the asterisk cli and watch what happens when you make a call (both in and out), enable either chan_sip or chan_pjsip debugging as appropriate also to ‘bracket’ the trace .

It would appear that packets are being sent and recieved

15098 [2021-08-05 22:38:53] VERBOSE[24625][C-00000017] res_rtp_asterisk.c: Got RTP packet from (type 00, seq 025684, ts 3284193888, len 000160)
15099 [2021-08-05 22:38:53] VERBOSE[24695][C-00000017] res_rtp_asterisk.c: Sent RTP packet to (type 00, seq 012015, ts 3284193888, len 000160)

That is one transaction of the A-leg of the call there needs to be also a congruent B-leg flow in response because asterisk is a B2BUA

presumably is your PBX and your VSP. you will need your router to return traffic from to (the port should be the same , yours isn’t)

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these you must restart Asterisk.

There is no other data then the stream I showed repeating the duration of the call. Not sure what the other half would look like.

I edited my post to add that clue . . .

your presumption is correct. So were do I go next? I presume that I need to add something to my router?

I suspect you router has a “SIP helper/ALG” enabled, if so it is not helping, your router should not be doing any ‘port translation’ in either direction.

For an EdgeRouter 4 you do this

set system conntrack modules sip disable

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.