No inbound audio to phone, but server receives audio

We were using SIPStation for testing our server until our regular provider got our new fiber connection up and running. Inbound and outbound calls worked normally with Sipstation. No changes to the server, other than disabling SIPStation and setup of new SIP trunk.

We can make inbound and outbound calls. The other end can hear us, but we hear no audio from them. If we check the recording, the server recorded their audio. So, audio is getting to the server but not the phone. Log from Asterisk -vvvr doesn’t show anything that jumps out at mean as a cause for the problem.

Same phone, same extensions, everything is the same except for the trunk. SIP Trunk connection is to a session border control device that does not require username and password, just host IP address. Trunk config is below.

Anyone have any ideas how to resolve this?

Outgoing Settings
Trunk name - providers name
peer details:
host - valid local ip address of eSBC

Incoming Settings
user Context - company name
type - user
context - from-trunk

Register String: (valid local ip address of eSBC, no NAT between this device and freepbx)

Figured it out. The new eSBC was connected on a second network adapter, a direct connection between the two devices. So two network adapters, eth0 connection to the eSBC SIP trunk, eth1 to the rest of the network. The IP range for the eth0 connection is Under my Settings -> Asterisk SIP Settings I had not added that range as a local network. As soon as I added that everything worked perfectly.