No files in tftpboot directory

I am having trouble with Digium D40 phones where they will not register correctly after a reboot. The phone attempts to fetch a config from DHCP option 66, and gives an error “error fetching configuration”. I’ve verified that option 66 in DHCP points to the IP address of my FreePBX server. When I check the tftpboot directory on the server, there are no config files - which I believe that there should be?

I am running FreePBX Distro 3.211.63-10, and have manually added the Digium Phones Module following the instructions listed here: https://wiki.asterisk.org/wiki/display/DIGIUM/DPMA+Installation

Am I missing something here?

Mike

One of the beauties of the Digium phones is not having to use TFTP.

License the DPMA for your install (Free), and install the FreePBX module.

Check this website for details and the module download (to be uploaded to FreePBX module admin manually).

https://wiki.asterisk.org/wiki/display/DIGIUM/Digium+Phones+and+FreePBX

If the phones are local to the FreePBX, they will be auto discovered by mDNS and wont need Option 66.

If the phones are remote, then use option 66 value as such:

sip:[email protected]:5060

There is NO tftp involved in this configuration so close your TFTP hole in your firewall.

Also, if using remote phones, be sure to change them to TCP mode, or extend the UDP timeout on your firewall to over a minute, or change the qualify frequency to under a minute, or re-registration time to less than your firewall’s udp timeout values.

This is a necessary step since Digium phones have a fixed NAT keepalive value of 60 seconds (or so their support tells me).

If you use TCP, then the keepalive/expire/qualify frequencies dont need to be messed with.

Thanks for your reply.

I’ve got the DPMA module installed, but it doesn’t seem like the mDNS process is working. When the phones boot up, they just go to a screen showing DPCP Option 66, with the soft key settings to change the server or keep the old config. I’m not seeing the screen where I can choose which extension the phone should be using.

Perhaps my DPMA module is not working correctly. I am able to see the phones in the FreePBX GUI under Connectivity/Digium Phones, but to get them working initially, I had to open the web interface for each phone and manually add the extension, password and IP of the server.

The phones are all on a local network, same subnet.

You need to install the AVAHI deamon for the Digium phones to find the server via mDNS. The minimal config is below. You can check out this link for provisining info

https://wiki.asterisk.org/wiki/display/DIGIUM/Provisioning

yum -y install avahi

chkconfig avahi-daemon on
service avahi-daemon restart

One more thing. To use the really cool features of the phones like the visiual parking lot or visiual voice mail you need to use the DPMA.

I’ve installed the AVAHI daemon, and now the phones are able to see the Asterisk option along with DHCP option 66, however when I select the asterisk server, the phone comes back with a message “Invalid Global Configuration Password”. I’ve check in the Digium Phones module and the Global PIN options are all disabled.

I’m about ready to scrap this entire installation and start fresh. Grrrrrr!!!

Well, I decided to go back to the AsteriskNOW distro,and everything seems to be working correctly. I think this is the best fit since we are running all digium handsets, and this distro had the Digium stuff already baked in. Thanks for the help though!