No extension registration attempt on asterisk cli - Extension registeration problem


(United States) #1

I am trying for last 2 days but no luck. From same IP, i can login to Freepbx portal so there is no blocking issue. However from same IP my extensions not getting registered. I used 5160 port and 5060. I am not even seeing any attempt on Asterisk cli. Other hand 2 trunks are registered ok. I made sure my IP is in whitelist.
Can anyone help? i been trying all day to fix this without any luck yet.


(Lorne Gaetz) #2

You don’t guess the port number. The port you MUST use will be identified at the top of the page when you edit the extension.


#3

At the Asterisk command prompt, type
pjsip set logger on
(if you configured pjsip extensions) or
sip set debug on
(for chan_sip extensions)

When your device(s) attempt to register, report whether any REGISTER requests are received and what replies, if any are sent.

If nothing received, run sngrep and report what (if anything) appears when your devices attempt to register.

If also nothing in sngrep, post details about the devices you are using (make/model for hardphones, software platform and version for softphones), how you configured them, router/firewall at the device location.


(United States) #4

I tried all 3 options. i could not find my ip appearing specially the lasat sngrep command was simply and easy to view. nothing… I am using zoiper softphone on android. I also have Astera 57i on same source ip. nothing is reaching to server. Though i am connected to Freepbx gui from same IP. I also put my ip in trusted ip list to make sure. still nothing.


#5

If sngrep is not seeing any traffic from that IP, then most likely:

  • phone not configured with correct IP of asterisk box
  • firewall blocking things

(United States) #6

SOLVED - ISP external firewall was blocking. now i see traffic from my IP.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.