No display of phone number with FreePBX 2.9

Hello we have an elastix version with a separate install of freepbx 2.9 with custom context module installed.
We have 4 extensions (3 phones + 1 fax), 2 Outbond Routes (GeneralOut and OutFax) and 2 Custom contexts (userout and faxout)
All phones use custom context Userout

From now on our provider let our freepbx manage the display of the outgoing number. We want phone number 00000P to be displayed for outgoing calls

We cannot find out how to configure our Freepbx for this to apply.

I am obviously ready to provide info from our settings.

Outgoing Caller ID’s are managed from the extension setup in a normal FreePBX setup, but not sure of the Elastix implementation.


“GeneralOut” Outbond route has
Route CID set to 00000P with Override Extension checked.

We have a Trunk Sequence named ‘MyDivert’ for this Outbond Route.

This “MyDivert” Trunk has of course following settings to


register=ABCDEFGHI:[email protected]/ABCDEFGHI

And what is displayed when we do an outgoing call is ABCDEFGHI, which is the an ID number (not a phone number)

All this info takes place in our sip.conf (or #include file.conf in sip.conf).

However as far as I understood about our configuration, freepbx 2.9 has been installed over the 2.8.X version of freepbx provided by the original elastix.

If you were using a real FreePBX, You should probably be setting the

Outbound CallerID:

In the trunk itself, (not the route as this has priority) using the proper format “ABCDEFGHI” <00000P>

Bothe fields are limited to 15 characters, however the number , within the < and > must be digits, but the last time I checked P is not a digit :slight_smile:

further, FreePBX 2.9 will break Elastix beyond repair.

Sorry, “P” is a series of digits
As a sample here is how it looks like : 003201234567.


“ABCDEFGHI” <003201234567>

That’s it

You are welcome.

Just read the documentation next time.