No direct script access allowed

I have a v13 freepbx PBX and after doing a backup, and updating the modules, It now says “No direct script access allowed”.

I have tried restarting it, fwconsole chown, I’ve reinstalled framework and core, tried repairing the database. Nothing works to access the gui. I know it should be upgraded and I know 13 is no longer supported. I checked out the error log but nothing is showing up when I go to the website

Thanks

A) Use another browser
B) Clear your browser cache

I have tried this on multiple browsers as well as using Chrome’s incognito mode. No change

Sounds like you’ll have to login locally to the machine, if at all possible. go to 127.0.0.1:[your http port] and tell us if you’re able to see the GUI then. If you only have terminal access, tell me if you ping google.com is it able to resolve or do you get DNS errors?

I can ping and resolve and connect to the SSH fine.

This is what happens when I try to connect locally

[[email protected] ~]# curl 127.0.0.1/admin/config.php
No direct script access allowed[[email protected] ~]#

I may not have communicated clearly… My mistake.

From inside SSH while logged into the PBX, type ping google.com

Does it show the ip and reply timestamps or does it fail to resolve google.com?

No sorry, it resolves everything correctly

Are you trying to get CRON to curl the page like a once a day type thing? If so, you’ll have to tell cURL that you have permission.
add the following to your CRON job

if ($_SERVER['REMOTE_ADDR'] != '127.0.0.1') {
    show_error("Daily CRON tasks can only be run from the command line on the live server.");
}

then add this to .htaccess

<Location /cron>
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
</Location>

No, im just trying to see if i can view it locally like you had asked and I knew curl was a way to do so.

Another v13 did the same thing today, after running mysqlcheck --repair --all-databases

I’d run a restore then use the legacy upgrade tool asap on those V13s