No dial tone on indial. But phone is ringing


I ran the online upgrade to FreePBX 13.0.109 and now when I dial in I have no dial tone on my mobile.
But the internal phone is ringing? This is for all extensions I try to ring.
I a baffled?
PBX Firmware: 6.12.65-22
PBX Service Pack:
Asterisk Version: 11.21.2
SHMZ 6.5

I have errors in the freepbx.log
You should go to the module admin page to fix these.)
[2016-Apr-30 07:32:33] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/ on line 52
[2016-Apr-30 07:32:33] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/ on line 61
[2016-Apr-30 07:32:33] [ERROR] (BMO/Notifications.class.php:487) - [NOTIFICATION]-[freepbx]-[modules_disabled] - You have a disabled module (The following modules are disabled because they need to be upgraded:

You should go to the module admin page to fix these.)
[2016-Apr-30 07:32:33] [WARNING] (core/ - Depreciated Function core_users_list detected in /var/www/html/admin/libraries/modulefunctions.class.php on line 2870

As it seems it actually only effects numbers which are in a Ring group.
Numbers which are not part of a ring group are working fine?

Try disabling Progress in the ring group. You might have to upgrade ring groups to edge.

I have since I posted yesterday restored from a backup and run through the manual update process but I have exactly the same issue again :frowning:
I am not overly handy with this software, what do you mean by disabling progress and upgrade to edge?

The obvious question: what value do you have for the "Play Music On Hold " field in the Ring Group that’s handling the incoming call. It should be “ring”. This non-intuitive setting fooled me until I realised how ring groups work.


Thanks for the quick answer. I checked that setting and it is set to ring.
The strange thing is that all our phones ring OK and everything works, it is just the caller has no dial tone and therefore doesn’t know that the call is actually working.

The way my phone system is setup, I have a Cisco ISDN gateway receiving the calls and then forwarding them to the FREEPBX who does the ring groups, the PBX then forwards the calls to the ring groups.
Calls coming through the Cisco gateway not going to a ring group work just fine so it is definitely the PBX not handling something correct.
And it only happened after the upgrade FreePBX Distro 10.13.66-1


Have you tried deleting and recreating the ring group?


yes I have tried recreating but that didn’t work.

I have now changed Asterisk from 11 to 13 and that seems to have fixed the issue.

Thanks for your suggestions