No channel type registered for 'VIRTUAL'?

I have my FreePBX 14 installation running and it works well.
Now I have an issue where I want to configure an internal only virtual fax. Our regular fax works well using an analog phone adapter. Now I want to use this fax (no. 25) to call an internal no (34).
It is used to scan/archive letters. Unfortunately I can’t get it to work.

I get these logs:
– Executing [[email protected]:55] Dial(“PJSIP/25-00000308”, “VIRTUAL/34,HhTtrIb(func-apply-sipheaders^s^1)”) in new stack
[2019-12-09 16:47:41] WARNING[17391][C-000001a4]: channel.c:6354 ast_request: No channel type registered for ‘VIRTUAL’
[2019-12-09 16:47:41] WARNING[17391][C-000001a4]: app_dial.c:2591 dial_exec_full: Unable to create channel of type ‘VIRTUAL’ (cause 66 - Channel not implemented)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:56] ExecIf(“PJSIP/25-00000308”, “0?MacroExit()”) in new stack
– Executing [[email protected]:57] ExecIf(“PJSIP/25-00000308”, “0?Set(DIALSTATUS=)”) in new stack
– Executing [[email protected]:58] GosubIf(“PJSIP/25-00000308”, “0?s-CHANUNAVAIL,1()”) in new stack

Any idea how to solve this issue?

TIA,

Hs

Assuming you want to use a virtual extension for fax to email.

Last time I tested, fax to email required a ChanSIP or PJSIP extension. But I might be wrong here.

If that’s not what you are trying to do, please explain a little better

1 Like

Last time I tested, fax to email required a ChanSIP or PJSIP extension.

Well, I have no hardware here and I want to use just fax to email. I assume that it won’t work with ChanSIP or PJSIP and therefore I used a Virtual extension…

Now I tried it using a PJSIP extension with Find Me/Follow Me enabled and It works.
So your clue was helpful to get a solution of my problem.

Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.