NO caller ID on incoming calls

configuration
Tags: #<Tag:0x00007fafcd73dac8>

#21

What is the IP of your trunk ? Make a call from your cell phone to your FreePBX external number and look for that IP on the INVITE message.


#22

That’s not coming from a SIP provider – it’s from your POTS to SIP gateway. It’s not configured properly to get the caller ID. Once that’s set, you should see caller ID without any changes to FreePBX.


#23

Is your trunk from a VoIP provider or from a PSTN FXO Gateway?


(Jared Busch) #24

Your grandstream needs to set the caller ID delay higher.


(Nice Guy) #25

IP of the trunk? Do you mean the IP of the server?


(Nice Guy) #26

pstn FXO gateway


(Nice Guy) #27

well… As far as the walk through on the freepbx wiki guide it should be configured properly.
any ideas as to what might be missing


(Nice Guy) #28

On Friday i set it to wait on 3 rings (according to what I’ve read its usually between ring 1&2 but it doesn’t work for me). When i set it to 4ring (which I believe is more than enough) I don’t receive the incoming calls.


#29

Have you connected a caller ID capable phone directly to the PSTN line to check if caller ID is actually being sent by your provider? If you have and it did get caller ID info then your Grandstream gateway is not set to the correct caller ID format. Check with your provider which format are they using: bellcore, etsi fsk, etsi dtmf, etc etc and configure the gateway accordingly.


#30

What country is the gateway in?
What is connected to (copper POTS line, fiber ONT, cable MTA, etc.)?
Have you confirmed that an analog phone connected to the line does receive caller ID?

Possibly, your PSTN line is configured with a service such as voicemail or forwarding unanswered calls that is intercepting the call before the PBX sees it.


(Nice Guy) #31

Yes I have tested and confirmed that the caller ID is being sent over the line and the caller ID scheme used is bellcore/Telcordia(It is whats we use for another clients UCM grandstream) and it works just fine.


(Nice Guy) #32

Country is set to St. Lucia I believe (I’m not on site at the moment, I will confirm later) and its connected to copper POTS lines


#33

The caller ID configuration must be made on the Grandstream gateway.


(Nice Guy) #34

yes it was. In fact it should have been automatically configured when doing the line analysis tests. So I’m just lost as to why it isn’t working/


#35

Have you checked if the caller ID is activated on the gateway? Look for the setting “caller id transport type”
The gateway doesn’t have a country setting, so not sure what setting are you talking about.


#36

Confirm that caller ID is failing on all lines. If it’s just one, the problem may be caused by other equipment or services (alarm system, DSL, etc.)

Use a butt set or similar to confirm that caller ID modem tones appear on the line about one second after the first ring.

Set up syslog on the Grandstream in Debug level and see what gets logged on incoming calls.

Confirm that Caller ID Transport type is set to default.

Try setting Rx from PSTN Audio Gain to -6 and also to 6.

See whether the FXO Line Connected field of the Status page shows the Caller ID on an incoming call.

Confirm proper AC Termination Impedance setting.


(Nice Guy) #37

“Relay via SIP From” is the caller ID transport selected


#38

is correct.

How many lines are connected? Have you confirmed that caller ID fails on all of them?

If so, I’d try syslog next. I’m not familiar with the device but would hope that if it can’t capture the caller ID, it would log one or more errors.


#39

Probably not what you wanted to hear, but if you setup a syslog server and configure it correctly, you can send the ‘publish’ the innards of the Grandstream, you can add the sip dialogs to the syslog stream, then add a syslog reader/analyser of your choice. (if you want to avoid the syslog inconvenience, you can just catch the steram on UDP/514 from the device

(Personally I would like a better debug thingy on the Grandstream, but (and after you get them working) you can’t beat the price :wink: the SNMP server is mostly useful also but will take a while to configure and nobody around here seeems to like SNMP :slight_smile: )


(Nice Guy) #40

2 lines are connected and yes it fails on both
I have no idea how to get the syslog working :sweat_smile: