No audio

Hi!
I am having problems with my remote extension. I do get the signaling ( ringing the phone both ways.) But there is no audio. I punched all the necessary holes in my fire wall; and nothing. I have no more hairs to pull! Can anybody help?
I exchanged e-mails with an Asterisk guru but he wanted 125/hr. I can’t pay that kind of money! With my vertigo attacks and all, I can very keep paying my internet connection.
Anyway, I put the server and the remote extension in their respective DMZ. I assume that by taking this route, I won’t be having problems with port forwarding. But I got the same results.
I suspect that my codes are messed up. This is what I have in my sip.conf:

[general]
#include sip_general_additional.conf
pedantic=no
bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=gsm
allow=ulaw
allow=alaw
allow=g729
maxexpirey=180
defaultexpirey=160
tos=reliability
; If you need to answer unauthenticated calls, you should change this
; next line to ‘from-trunk’, rather than ‘from-sip-external’.
; You’ll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown

; Reported as required for Asterisk 1.4
notifyringing=yes
notifyhold=yes
limitonpeers=yes

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf
nat=yes
externhost = myphone.hopto.org
localnet=192.168.0.0/255.255.255.0

Can someone who knows take a look at the order of my codecs.? I know that 99% of the time the audio problems are due to bad NAT. Please note that I changed my DNS to a more generic. My real DNS name is working just fine.
In my sip_nat.conf I have the following:

nat=yes
externhost=myphone.hopto.org
localnet=192.168.0.0/255.255.255.0
externrefresh=10

Once again, by putting both the server and the remote extension in their respective DMZ, I should not have any port problems. Right?

I have read many posts with similar problems as mine. I tried changing what they suggest but I am still in the hole.

I hope to find help with this issue.

Thank you everybody!