No audio on remote extensions

I recently changed my ISP which gave me a new static IP a new (bridged) modem and a new router (Asus RT-N66U). My PBX was working well before these changes but now I’m having audio issues.

I have 4 remote extensions at a satellite office that connect over WAN. These phones are registering but I can not seem to get any audio through to them. Even calling from an extension on the same network as the PBX to the remote extension, no audio is transmitted. I do have one IAX extension on my cell phone Zoiper app. If I call that the Zoiper IAX extension can receive audio, but not send audio.

On my router, I have port 5060 UDP/TCP forwarded to my PBX and ports 10001:20000 UDP forwarded to the PBX. I followed the guide below to adjust my SIP settings and the RTP ports to 10001:20000. My router also has NAT enabled for SIP and firewall enabled.

I’m at a loss for what to try next. I would imagine this is a router issue since that is the new variable, but It’s also possible there may be some IP address setting in my PBX that I have not changed.

Any help would be appreciated.

I never got SIP/RTP over NAT work very well either on my setup. I often had one way audio. (Zoiper and IAX worked fine though)
Then I put my remote phones on VPN. I use Yealink T23G and run an openVPN server on my LAN.
Just a suggestion.
This works very well for us and is also recommendable from a security point of view.
This also solved issues with dynamic IP addresses changing on the remote client side. We had port 5060 only open to known IP addresses, otherwise you get hammered with hacking attempts.

Below is a thread you can check out on same issue.

Welp, I was frantically digging and found a solution. Actually on one of my old posts on this forum!

There must be something with the Asus RT-N66U that causes this. Both times the PBX has been behind one and both times switching “IP Configuration” to “Public” has solved the issue.

This is causing me an issue again. Looking for help.

When I first had the problem, changing the IP Configuration from “Static IP” to “Public IP” in the Asterisk SIP Settings>Chan SIP menu. A couple days later, the issue happened again. I reversed my change, moving from “Public IP” back to “static IP” and my problem was solved. Now one day later, the problem happens again. And, moving back from “Static IP” to “Public IP” fixes the issue.

What am I missing here? How can this be fixed permanently?



Make sure that your SIP ALG is closed on your router. Here is a little manual that I have found for your router. Check your firmware and follow these settings:

Asus RT-AC66U devices with their most current firmware enables their SIP ALG by default. THERE IS NO GUI OPTION TO DISABLE IT
So as to add to your knowledge base, I thought I would share the solution:
To disable the SIP ALG manually, you enable telnet to the device via the WWW interface
Telnet to the device (from a command line enter "telent" or the appropriate IP address for the device.)
Issue the following commands:

nvram get nf_sip 

(It should return a "1")
nvram set nf_sip=0 
nvram commit


Then reboot the router for the changes to take effect.
Under firmware SIP ALG is located in (via the web interface):
1. Log into the router's web interface.
2. Go to Advanced Settings / WAN on left side.
3. From the tabs across the top, choose NAT Pass through.
4. Change SIP pass through to "Disable." Hit apply.
For phones to pick up the change immediately, reboot each of them, 
otherwise they will pick up the new NAT table with changes during their 
next registration.

You can take a look directly at this link:

Thank you,

Daniel Friedman
Trixton LTD.

Thanks for the reply. I have now disabled the SIP pass through under NAT pass through. Now the phones work with “Static IP” selected in the asterisk SIP settings but not when “public IP” is selected. This seems like the right configuration so I’m going to give it a few days and see if the problem persists.


It is good to hear that it solved your problem.

You should work with static ip in a NAT environment. The pbx must know to which public ip translate its local networks. The public ip is when your pbx has a public ip and you are not in a NAT environment.

Please report back.

Thank you,

Daniel Friedman
Trixton LTD.

Two days in and we do not have the problem anymore. I appreciate your help. I’ll report back next week to confirm the problem is still fixed.

7 days with no problem. That seems to have fixed it! Thanks Daniel!

1 Like


You’re welcome.

Thank you,

Daniel Friedman
Trixton LTD.