No audio on remote extension

I’m not a network expert, just know enough to be dangerous!
Running FreePBX server in my office with two Panasonic KX-UT123. Works great.
Have an IPSec tunnel setup from office to remote site, two identical Ubiquity Edgerouters. Tunnel works fine. Can ping/login/manage devices at either site from the other end. Office is static IP, remote site is not.
Set up third KX-UT123 at remote site & it registers with FreePBX at office. Remote extension rings on incoming calls, successfully makes outgoing calls but no audio in or out in either case. Call setup/breakdown works on both extension-to-extension calls and calls to/from the PSTN.
Both routers are set to ‘automatically open firewall and exclude from NAT’. Both office and remote LAN IPs are listed as local networks under FreePBX SIP Settings.
One odd thing, I compared IPSec configs between the two routers and both are set to “connection-type initiate” Shouldn’t the remote (dynamic ip) side always initiate the connection to the office (static ip) site?
I understand that the problem is likely RTP related but as I said, I just know enough to be dangerous. Help, I don’t know where to go from here.

Is the subnet range for the VPN IP included as a local network in Asterisk SIP Settings?


Thank you for responding to my question.
Yes, both the local and remote networks ( and are listed under the General SIP Settings tab under Asterisk SIP Settings.
I noticed a text box for local network under the SIP Settings [chan_phsip] tab. That is blank. Does this also need to list the remote network address?

That was it!.. I had both local and remote LAN addresses listed under the general SIP tab for Asterisk SIP Settings, but it did not start working until I added the remote address under the chan_pjsip tab. I did a restart and Voila! it worked. Thank You!

I’m glad that you got it working. However,

This should not have been required and you may have found a bug. The intent of Local network on the pjsip tab is to define a per-interface local network, in addition to those already defined in General SIP Settings. Possibly, the pjsip driver is only examining the first General entry.

However, when any of these are changed, one must restart (not just reload) Asterisk for them to take effect.

If you are sure that the necessary restarts were done before you added the pjsip-specific entry, please file a report at .

If not sure, please test whether removing the pjsip-specific Local network (and restarting Asterisk) causes the audio path to stop working.

(The above all assumes that the PBX has just one NIC. If you have multiple, please describe the setup.)

Hi Stewart,
well it may be more complicated that I first assumed. I was becoming frustrated is IPSec and after much web searching I decided to implement an openvpn bridge at both ends of the link. I setup the bridge but that did not make any difference to my no audio problem.
Later I saw Lorne’s question and went to double-check my settings. That is when I noticed and added the remote address under the pj_sip tab and did a restart (core restart now using the CLI) that is when things began to work. So is it the openvpn bridge or something else?
I can do more testing tomorrow when there is someone at the other location.
No, only one NIC.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.