No audio on internal calls

Greetings,

I’m not able to get my NAT settings and firewall setup correctly.
I’m running FPBX-14.0.5.25(13.22.0), Distro behind MikroTik router.
I have Ports 10000-2000 forwarded to server (192.168.5.7) allowed from anywhere
and port 5060 forwarded only from two external IP address for two remote phones.
This setup works as follows:
Outside Extensions can make calls using trunk lines without issue.
Calls from External Extension to internal extension get’s one way audio (internal can hear)
Internal calls using trunks can hear outside party, but party can’t hear.
Internal calls to internal extensions (all behind same router in same subnet) no audio either direction.

I’ve tried changing NAT setting In “Advanced settings” (no,yes, routed) none of which seem to impact.

I’m not understanding how to interpret call trace so I’m asking for help.
The following is from an internal extension to extension (server and both devices on same subnet
and behind same router). What stands out to me is " Contact: <sip:47.20.xx.xx:5060>" which
is the public ip of the network, same as “External Address” in under .

I have also tried entering local network as 192.168.5.0/24
and 192.168.5.0/255.255.255.0

Previous version of FreePBX had NAT settings in the extension
setup. I don’t see a GUI option for setting NAT on an extension basis.

Any and all help is greatly appreciated.

https://pastebin.com/embed_iframe/5VwgErA6

Solved.

Finally figured it out. I had a bad firewall rule.
When forwarding ports 10000-20000 I selected rule
to include/require in interface=WAN on router. This caused
internal ip’s to fail to forward to PBX.

Yet another lesson learned!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.