No audio on inbound or outbound calls

I am running FreePBX with Asterisk version 15.1.5. I am using an old ObiHai 110 device as an FXO port and a Gigaset C530IP DEC station as a PJSIP extension. Both devices register with PBX and calls can be made and received but there is no audio in either direction. When calling the extension’s voicemail, the logs show that the proper audio files are played by the PBX, but no audio is received at the extension. The handset does indicate the correct number of new messages and I can leave new messages when calling from an external phone.

Suspecting that this may be a configuration issue of the audio codecs, I have ensured that the C530IP is configured to use codecs specified as allowed in the general SIP settings in PBX.

FWIW, I had set up the DEC station successfully previously but while moving all devices and servers involved to a new VLAN, I had to reset the station to factory setting. Subsequently, I am no longer able to use the auto configuration “wizard” of the device, which I believe has gotten me there last time with some minor customization.

Any help would be greatly appreciated!

Your phones and PBX are on the same network?

Yes. And they all talk to each other as indicated above. Phone rings on incoming calls, PBX connects outgoing calls and they arrive at the destination, phones can access voicemail and PBX plays voicemail files as indicated by the logs… all that is missing is the audio.

Sounds strange, audio issues between extensions is usually when the phone (or phones) are behind a firewall.

Did you try a server reboot?

Also, place a call and post the logs here.

I will try the server reboot this afternoon, when I get home. In the meantime, I have the logs for an outgoing and an incoming call I made last night. Unfortunately, I don’t see an option to post these at this time, since I just signed up last night and I cannot post links and they are too long to include directly.

The pastebin dot com ids are HVhphV1s and UYRTxXfc respectively. The obfuscated phone numbers (000{1,2,3}*) correctly reflected my CID and the numbers of the called or calling phones.

OK, this is frustrating… I turned it off and back on again and now it works. Restarting PBX, that is, actually helped!

1 Like

This points to a possible configuration problem with your firewall or (less likely) one of the other routing components in the network. I expect that it will stop again in an indeterminate point in time.

Can you elaborate on why you think that all the other networking was there but only audio was missing due to a firewall configuration issue?

I recently had with PJSIP that it also did not have any audio, while CHANSIP worked fine.
A reboot fixed it, so yeah…

SIP registration and interoperation happens on port 5060 (and others). This port is often allowed through the firewall and is sometimes allowed to work through routing parameters on the hardware (your PBX firewall, your LAN firewall, local routers, routers at the phone location, etc.).

Audio happens through a handshake relationship on a “per call” basis and is established when (and only when) a call is established.

As such, port 5060 will often stay connected (BLF, re-registrations, etc.) but the audio ports can shut down through inactivity. Without logs and config information (which you have access to on the server), it’s a guessing game. In the past, we’ve seen cases where audio will work for a day, or an hour, or as little as 32 seconds. Without properly configured network equipment, the audio ports can be blocked or allowed, sometimes seemingly randomly.

All devices are on the same network. The firewall on the PBX is turned off. Routing on the network is wide open on the only router in the mix. Other than changing subnets and upgrading to the latest version of PBX, no changes had been to a working configuration.

Did you have a chance to look at the logs that I posted on pastebin?

“Other than changing subnets” stands out, did you do that both on your network _interfaces/routing AND in the GUI?

set sip debug on will add stuff to your log that can identify the problem that the standard logging wont show

Yes, all the settings I could find were changed to the new subnet on all the devices. The PBX had been rebooted several times in the process as had the SIP DEC station. The latter was the last to be joined on the new subnet and without changing anything in the PBX settings, a reboot took care of the missing audio issue… being very familiar with networking, firewalls, and routing, this is what is so frustratingly perplexing for me.

So if it is fixed, then problem solved, if it reappears , then try setting “sip set debug on” , it reveals the packet traversal through the various networks and reveals any SDP ports that are claimed/invited on those routes, you can get a quick synopsis of the RTP progress with “rtp set dubug on”


Will do. FWIW, tcpdump on the router’s interface showed a large amount of traffic during calls when audio was missing. That traffic was over the RTP port range.

But apparently not completely end to end and bidirectional or the would be at least some noise. Each call should be over an even port out and the sequential odd port back, and within the range as defined , by default 10000-20000, to debug you might restrict that range to 10000-10001 and concentrate on one call at a time. it makes for n easier call to tcpdump, another tool you might well find interesting while working with SIP is “sngrep” which is basicallyu an ngrep tuned for sip.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.