No audio on either end on calls from outside to inside or vice versa. Internal works fine


We’re testing FreePBX to see if we can use it to replace our aging Avaya IP Office.

We have two extensions set up temporarily, just using tablets with softphones (Zoiper). We can call from one extension to another and all is fine.

When we call from an extension that is set up OUTSIDE our firewall, we connect, but have no audio on either end.

We have Meraki MX firewalls, and have port forwarded 5060, 5061, 4569 and 10000-20000 to the internal IP of our FreePBX server.

What are we missing?

Thank you!

One-way audio (even when it’s happening both ways) is a result of not properly identifying the NAT situation in the server configuration and in the extension setup (both on the server and on the endpoint).

First. check the SIP settings (under the Advanced tab) and make sure that the system is set up for NAT. The external address (the routable address on your WAN to LAN connection, or the external address of your Meraki.

Second, make sure that any SIP-ALG or other “SIP Helpers” are turned off on the Meraki. These work fine if you are connecting a phone, but you need a lot more control over the traffic with the server in the mix.

Third, check your Extension configuration and make sure that you have enabled the NAT settings. There are several choices there, it might take a couple of tries to get things like voicemail notification and audio to all work at the same time.

Finally, check your phone app’s setting and make sure the external address of the phone (the routable address) is correctly identified in the setup. This may require you to set up the STUN settings (it depends on your network at the remote end) for the phone, especially with Voiper.

Thanks Dave,

I’ll look all your emails over later. We are in the middle of a PIN pad upgrade in one store this week, so I won’t have any time until later to investigate.

I’ll be in touch.


Hi Dave,

I just enabled STUN (using default) in my Zoiper on my Android, and had my son do the same, and we were able to call from outside to inside. There was quite a delay at first, I think due to poor wireless service, so I moved to a spot with better cell service, and it was decent. Could call outside->inside and vice versa. Tried video, but that did not work, but that’s not very important right now.


There has been no small quantity of chat here about video calls. It might be an Asterisk thing, or a client thing. Either way, it appears that once the connection is set up with a specific codec (for voice, for example), the video codecs are never tried, or if they are, they don’t catch like they should.

For these types of external calls, video is usually unsatisfying anyway. VOIP over 4G or WiFi is usually too laggy and jittery to give you a good connection, and so you end up with laggy calls or calls where the video (or even the audio) just doesn’t work very well. Lots of people have tried “cell wireless” setups and lots are not happy with the outcome, some even within a well-controlled local network.

If you are interested in getting the vide working, I suggest your dredge back through some of the discussions here and see what the issues and solutions are. If you get jammed up completely, we’re still here to help.