No Audio on calls to some numbers

This is kind of a weird, but for some reason there is no audio when I call a specific number.

When I try to call my voip service provider (fpl), the line shows its been answered but there is no audio.
If I use that line to call anyone else it works perfectly. Only this one number has issues.

So I tried to use my secondary voip service to call my first voip provider it works (but I have to pay for these calls so not preferable.)

So to make sure it wasn’t my first provider having issues, using CSip I entered my fpl credentials and called the number having issues, it worked. Great, so I went back to my voip device and called with fpl, and still doesn’t work.

So it seems this voip account can receive and make calls to any number, except when through freepbx it has issues with this one number (no audio).

Any suggestions?

I have this problem with Voip Innovations. If I call them on the line I have from them, the audio fails. I also have this problem with calls that enter the system from outside and get sent out to another external number.

I’ve always assumed it was a NAT problem. To solve it, I got a second trunk through CallWithUs (outbound only) and directed all of the “problem” numbers (cell phones, VI, etc.) to this other trunk.

I don’t think it’s nat because:
VOIP phone->freepbx-Router->internet->provider (fpl)
Andriod sip software->router->internet->provider (fpl)

And the first mode allows incoming and outgoing calls with that account to all other numbers.
Second mode allows in/out everywhere.

Calling this number when not using their service can be costly which is why I would like to use the service. And I am calling the service provider (fpl) with their own service.

Did any one get to the bottom of this. I have a similar problem as explained below:

I have FreePBX connected to a sipgate trunk (Basic) and a voipfone trunk.

I have two internet connections, one BT through a homehub (Backup) and a a main WiFi link connection using ppoe (pfsense) firewall.

When connection through the main link, I can call a lot of numbers and two way audio is fine. But with certain specific numbers will ring but when answered I can’t hear the other person however they can hear me. I have directly connected one of my Yealink phones to sipgate and the problem still exists. The numbers don’t change, if I cant hear a person on a number I can never hear on that number, but if I can hear a number it always works!

The pfsense firewall has been configured with manual outbound NAT and I have all the ports forwarded back into the PBX as per requirements. I have also messed around with scrubbing and using conservative mode to no avail. However if I put the SIP trunck connection through my BT line with no configuration of the firewall the whole system works perfectly!

When watching asterisk and pfsense logs I can see the connections and ports and they are all allowed and don’t look to be getting changed.

I have tried ClearOS as a firewall as well but that exhibited the same problems so I have come to the conclusion (rightly or wrongly) that perhaps it is something to do with the main connection being PPOE perhaps as this breaks vodafone sure signals as the MTU is not large enough. However it is curious that it is only specific numbers that have the problem.

To add to the confusion if I use the voipfone trunk calls work perfectly even to the numbers that dont work through sipgate. (I’d like to get sipgate working as its cheaper)

I don’t know if anyone else out there is using a similar setup with sipgate or has a bit more knowledge as to what might be causing this issue?