No audio in either direction

This system WAS working until recently. I am using a variety of phones, including Polycom IP 501 (yeah…old ones), Linksys ATA (don’t recall model), Grandstream and even a twinkle softphone. All of these WERE functional at one point. Over the past few days, the Grandstream and the LInksys ATA quit working at all and were not registering even. I have, in testing removed ALL nat between the PBX and all phones. At this point, there is no audio in either direction. This is true whether I call outside the system OR extension to extension. I have a log that may help, but the forum doesn’t allow me to post it in it’s entirety. I am not sure even where to look beyond this. If anyone has ideas how I can post the log, let me know.

Paste the log at and post the link here. If the forum does not allow you to post the link, replace the last . with %2E for example
The above line will still function as a link if pasted into the address bar. In most browsers you can triple-click then right-click and select go to.

In Asterisk SIP Settings, check that External Address and Local Networks are set correctly.

If that’s not your issue, at the Asterisk command prompt, type
pjsip set logger on
make a failing test call and paste the new log (which will now include a SIP trace).

AFAICT, there are (at least) two things wrong, as I can’t think of a single problem that would explain everything in the log.
Log line 382:
Via: SIP/2.0/UDP;received=;rport=5060;branch=z9hG4bKPj356a0dee-04a8-49e9-acde-bd230e70fda2
This is from the 183 sent back from Flowroute. 172.20.x.x is a private address (not routable on the internet), so you would not have received this packet if that’s where they sent it. So, it appears that your router/firewall has a SIP ALG enabled that is mangling the SIP traffic. Find the setting for this and turn it off. If you have trouble, post firewall make/model.

Line 354:
c=IN IP4
This is in the SDP in the INVITE sent to Flowroute.
Is this your public IP address? If so, ignore the rest of this paragraph. Please confirm that in Asterisk SIP Settings, External Address is set to your public IP address. On the pjsip tab, External IP Address and Local network should probably be blank (please explain if not). After changing any of these settings, you must restart (not just reload) Asterisk.

If you still have trouble after fixing the above, post another log.

Oops, I apologize. I just looked up and see that you have a public /24 there. Just fix the ALG and with luck you’ll be good to go.

1 Like

I turned off the ALG helper app. No change. I have the .83 public IP 1:1 natted to this server, so it is forward 100% of the traffic to the server, so there should be no need for that ALG anyway. It was on by mistake (replaced equipment a few weeks back), but it has worked SINCE that replacement. I think it was about 2 weeks ago that the problem started. Any other options? I am in dire need of help here and can pay someone to fix it if needed.

This isn’t rocket science. Capture traffic at the PBX e.g. with tcpdump, move it to your workstation and look at it with Wireshark. If audio is coming in, it shouldn’t be hard to figure out why it’s not getting to the extension. If not (and the SDP in the outgoing INVITE is requesting that it be sent to the right place), then capture traffic on the WAN side of your firewall to see if it is being blocked. If it’s not there, either, and you’re sure that your INVITE has the correct SDP, you might open a ticket with Flowroute.

Are there other trunks on your system? If so, who and are they working? If you have no other trunks, I recommend getting an account with Telnyx or AnveoDirect. Both offer a small credit at signup so you can test without making a payment. Most importantly, both have online access to SIP traces for each call, so you can easily see where the audio is going and if anything in your network is messing with the traffic.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.