No audio from both sides using dyndns

hi folks,

i have checked this post for common audio problems

however i am still unsuccessful.

all was working well on my freepbx server till i changed my router yesterday.
my ip changed when i inserted the new router so i decided to get dyndns.
my new router is successfully connected with my user name and password to dyndns.
i re-forwarded all the necessary ports to my server 5060, 10000-20000.
Using the remote extensions GUI settings in freepbx (asterisk sip setting) i changed my previously working settings and just swapped the expired ip with my new dyndns domain. i then did a test by trying my raw ip address and it works just fine. so for some reason using the dyndns name doesnt work.

my asterisk sip settings are as follows.
nat is yet static is selected and below that is my dyndns address.

im using the latest updates of freepbx, also i am using asterisk-now with asterisk 1.6 or 1.7

i hope i provided enough info for you to help me otherwise just let me know!


your help is much appreciated, please let me know if i can provide more information.

here is my /etc/resolve.conf

; generated by /sbin/dhclient-script

search localdomain

does anyone have an answer for me, each time i play with my router i need to re-enter my ip manually cause entering the dyndns addy doesnt work for me. i cannot seem to get the configuration right!

your help is much appreciated

I swapped out my router and lost audio. My touchtones were not being recognized.

Your post reminded me of the extra forwards in the 10,000 to 20000 range. I then remembered that I also had to hardcode IP addresses in some files but did not document which files.

I used Webmin’s file manager search for a partial IP address I remembered and found 2 files I had modified.


I went back in an updated those two files and rebooted and now my touchtones are working again.

Don’t know if this will help you or not.

oops, i accidently posted in the wrong thread.
my audio works fine but im using the ip given to my router in the Sip settings where as i want to you my dyndns address instead.

thanks for your suggestion anyways :-p!!