No Audio - Freepbx with Asterisk V11

Hi Guys/Gals

I have no audio and it does seem like I’m missing something small. Here is a small output from rtp debug. It does send and receive audio…? But if I call nothing happens… Any clues? What do I need to post to make resolution easier?

[2014-08-22 17:10:05] VERBOSE[5785][C-0000000c] res_rtp_asteris k.c: Sent RTP packet to (type 00, seq 005754, ts 065240, len 000160)
[2014-08-22 17:10:05] VERBOSE[5785][C-0000000c] res_rtp_asterisk.c: Got RTP packet from (type 00, seq 019585, ts 065760, len 000080)

To add, the pbx runs behind TMG.

tmg address:
Sipconf not manually edited

Also error in log. nat=yes deprecated use force_rport intstead

I don’t know what a TMG is but it looks like it is unhelpfully translating the RTP port/not passing the RTP traffic for the voice stream. It is unnecessary to have a firewall between hosts on your private network.

Hi Dicko,

thanks for the reply. TMG is a firewall from microsoft. It sure is not helping with the package translation. As the router has no firewall setup I don’t want to place it in the permiter network. Will post something if I find a solution in the meanwhile


both hosts are in the same network. Why do you have a firewall involved at all for that traffic. Firewalls belong on the edge of your network, presumably between xxxxxxxxx and , even ones from micro$oft.

What wouldbyou recommend doing? Just to explain the setup in a bit more detail…
firewall has an internal nic in range with is the same for freepbx.
the external nic is directly connected to the net and has a few static ip’s
the gateway that the firewall points to has no nat setup with only routing that passes the ip as is. Addresses are natted @ the tmg.
I have at the moment no need for remote extensions.
If I get what you are saying I should set nat to no or never?

Personally I would just get a real Firewall :wink: . (But bear in mind that I am the last person here to have anything useful or constructive to say about anything M$)

You have left out a bit of critical info. Is this audio problem occurring between two endpoints on your internal network? Is it happening between and endpoint and a SIP trunk? What version of FreePBX? Is it a FreePBX distribution or hand built? Do you have in the local net in SIP settings?

BTW. Found this in reference to TMG.

On 9 September 2012 Microsoft announced no further development will take
place on Forefront Threat Management Gateway 2010 and the product will
no longer be available for purchase as of 1 December 2012. Mainstream
support will cease after 14 April 2015 and extended support will end on
14 April 2020

Hi Alan,

thanks for the comment/reply.

to answer your q’s: the audio works fine from inside the network. Ie, if one extension calls another. When I call the sip trunk from a cell or landline no audio goes in or out. Strangely dtmf tones are recognized from both ends.

It is a freepbx distro. V2.11.0.38 64 bit version.

@dicko. I’ve worked in several evironments with MS FIREWALLS, but also prefer linux based firewalls and ‘hardware’ firewalls. They seem to be a lot more versatile and configurations take up much less time by using cli as to gui’s. Unfortunately I do net yet have the authority to make such changes to our network and will have to make do with what I have for now. I will be presenting a change to move to a different firewall as soon as I have established the needs and requirements of our company. Atm I’m gathering this info

If your original post shows such an attempted call to your voip vendor and you have set up your Asterisk NAT correctly, then your M$ thingy is showing all signs of it trying to be a proxy for your SIP sessions, it only needs to effectively and transparently perform Network Address Translation (NAT) for the SIP session , and then just pass the RTP traffic with NO Port Translations for the negotiated SDP session, effectively just a dumb SIP pass-through device. If you want it to proxy effectively then that is a whole different ball game.