No audio, Calls still go through

freepbx
bug
Tags: #<Tag:0x00007fafce288310> #<Tag:0x00007fafce28fde0>

(Matthew Jensen) #1

I recently set up a couple of remote extensions and I’ve been experiencing problems with them. My server is hosted elsewhere, so technically all of my extensions are remote, but these new ones have been especially troublesome, while at our main office the phones work perfectly.

I’m not currently posting any technical information because I’m not sure what is needed to diagnose this issue. I can update with logs or other technical information with guidance as to what I should post.

Here is what is happening:

I can make calls with these extensions, either to other extensions or to an unrelated phone, and the other party receives the call. They can answer, and they show as connected. But only sometimes does sound go through, mostly it does not. It seems rather hit and miss. There is a possibility that making a call after waiting a long time seems to have more success, but I’m not sure if this is the case. Also, sometimes after waiting for around 20-30 seconds, the call will “connect” again, and sound will go through. But again, this is not always the case. BLF info is coming through as well. And they are listed as OK in the astierisk infos peers section.

I have tried changing sip settings to nat = yes.
I’ve tried temporarily disabling iptables, even though our IPs are whitelisted here. (I’m using travelin man)

One thing that may be the problem is that we bounce between a couple of public IPs rather frequently. Could that be the problem?

I’m tripped up because this problem seems so hit and miss. Do you guys have any suggestions? I can post more information here if it is needed, but what I really need is another place to look for the problem.

Thanks so much.


(Itzik) #2

This is likely an issue with the Remote Locations Firewall. Some firewalls you have to enable or disable specific settings in order for your SIP Devices to work properly.

Tip: these phones need a stable connection, not a fast connection.
Tip: these phones sometimes can’t be behind two router’s (NAT + NAT)

Good luck.


(Matthew Jensen) #3

Thanks for the advice. Sorry I haven’t responded in so long. I’m 95% certain the problem lies in our load balancing system. When we switched to just using one line (internet line), the problems seemed to stop. I’m writing this to help anyone who might be experiencing this, but also as a request for advice on the best practice for using load balancing systems alongside VoIP. Should I attempt to route all VoIP traffic through just 1 line (again, internet line), and load balance the rest of our traffic through the other and what is left of the first? Have any of you implemented load balancing alongside VoIP? What are some of the things I need to consider? Thanks.


#4

I setup a number of systems exactly how you had explained. VoIP is dedicated to one specific internet connection except upon failure where I would send all the traffic out of the second internet connection.


(Drslei31) #5

@matthewljensen did you manage to find a fix for this? Run into the same problem whilst using a Network Load Balancer to direct to individual asterisk servers. Would greatly appreciate any info!


(Matthew Jensen) #6

@drslei31 This was a long time ago, but my recollection is that we were unable to configure the loadbalancer in a way that wouldn’t cause problems. We ended up using a dedicated internet connection for all voip communication.