No audio Call recevied

Hi Everyone,

First of all, I would like to appreciate all community members for giving their support to users like me (newbies).

I have implemented a FreePBX distro in Hyper-V VM and it works perfectly. No issues whatsoever.

Then I moved FreePBX to a private cloud. Then this issue kept coming. I can register softphones to the FreePBX and can ring extensions added. But after answering, no audio for both side. I saw a few topics like this but I couldn’t figure out how to overcome this issue. Following are the details of the server and FreePBX configurations.

Freepbx latest distro - V16
IP addresses
FreePBX server interface IP - 192.168.108.34 (private IP for server)
But it also has 10.250.xx.xx IP address and from this IP connects the softphones.
Softphone IP range 10.23.xx.xx

I want to make only internal calls. No need for internet and no internet is available for the server.

Thanks in advance.

@SkykingOH Can you kindly check this and please let know your thoughts on this?

I have the same problem, tho mine is an on premise system and local phones work phones, remote phones have the same problem. If you call *43 for echo test, do you get audio?
What version of asterisk?
From the cli run asterisk -rvvvv then “rtp set debug on” and make a test call and post the results in a pastebin link. I’d like to compare with mine.

Don’t forget to “rtp set debug off” when you’re done.

1 Like

Hi. I have tested it in a VM. Then it’s working perfectly. Both ways audio works. I saw some guys say that this is a NAT issue. I couldn’t figure out to resolve this.

Asterisk Distro 16
Yes, I can hear the Echo test in both scenarios.

Maybe declare your different networks under Nat Settings.
External Address:
Local Networks:

Check if there is another firewall filtering your RTP ports upstream.

Usually this kind of stuff is a NAT issue.

1 Like

Hi. thanks for the reply. Can you kindly mention where I can find RTP ports upstream? FreePBX firewall or ??

Do you mean to change the sip. conf configurations? But NAT is used when the server is accessible through the internet. my server doesn’t have an internet connection. All the calls I made to test are internal.

DId you mean the entity, that is upstream, and which is restricting your choice of RTP ports. That would mean a firewall in a router, or NAT settings in a router. That router could be anywhere between you and the peer.

2 Likes

If your server is on the cloud, how your extension can connect to your server?
VPN only?
In this case, set your Local Networks: here

If your server has 192.168.108.34 , that mean, it is on a local network, something like that maybe : 192.168.108.0/24
If your extensionsis included in this network 10.250.0.0/16, then you must add this network too.
Asterisk have to know this network.
In the case the VPN provides a network with (e.g) 10.10.2.0/24, you should add it!

1 Like

Browse the forum with No audio as key word. I think there is lots of thread about that.
Maybe you can find your case in the result.

1 Like