No Audio between soft phones on same PC


(United States) #1

Hi All,

I am new to FreePBX and am trying to use it to handle a routing issue between a hosting provider and a SIP enabled Mass Notification System. In order to get myself going, I have installed FreePBX 16.0.10.14 on a VM and one my PC I have two soft phones registered as ext 3000 and ext 3002. The PC and FreePBX are on the same subnet. The Windows Firewall and FreePBX firewall are disabled.

I can place a call from either extension to the other successfully, but I get no audio in either direction.

I can call #43 from either extension and send and receive audio.

I have run wireshark on my PC and when using #43 see the call setup and subsequent RTP packets in both directions (of course). When I try to call from one extension to the other; however, I see the call setup, but no RTP stream.

I have tried enabling call recording to force audio to pass through FreePBX but still no RTP traffic.

I have limited the CODEC to ulaw, but have also tried with other CODECs enabled.

Any suggestions would be greatly appreciated.


#2

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, after Submit and Apply Config, you must restart Asterisk.

Possibly, there is a quirk in the OS or the virtualization system related to two softphones competing for the same resource. Shut one of them down and set it up on a mobile device (connected by Wi-FI on the same LAN subnet) or another PC.

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
make a failing test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here. If you are too new to post links, post the last 8 hex characters of the URL.

The above assumes pjsip extensions. If you used chan_sip, please explain, and replace the above command with
sip set debug on


(United States) #3

LOL, I rebooted and now I have two-way audio! Thansk for your help.


(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.