No Audio After FreePBX Upgrade v13 to v15

We have recently attempted to upgrade our FreePBX from v13 to v15.


  1. Fresh install of FreePBX v15 from ISO on ESXi Server
  2. Configured New and Old FreePBX using SIPSTATION - All trucks and Inbound Routes added automatically
  3. Both the Old FreePBX and New FreePBX are on the same ESXi Server
  4. Old and New FreePBX are behind a Hardware Firewall using an Internal IP address separate from the Public IP
  5. We kept the old Internal and Public IP address on the new FreePBX Installation - No changes to the Hardware Firewall
  6. The New FreePBX Starts and Connects without Issue to SIPSTATION (All Reports OK)
  7. All Extensions are either Virtual or Fax - no SIP Phones are being used
  8. When an Inbound Call is made we can see the appropriate traffic within asterisk (using asterisk -rvvvvvvv) We see the call being answered and the digits being voiced.
  9. For the purpose of the above test - we used a non VoIP phone - so it would be from an outside network / system.

Issue: We are not able to hear anything on the phone, it is complete silence until asterisk completes the digits being voiced, and then it hangs up.

When we stop the New FreePBX and start the Old FreePBX, everything works fine. We can hear the voicemail when dialing on of the numbers.

We assume this rules out the Hardware Firewall, the Network, and possibly the OS - however, we have been unable to find any NAT setting within FreePBX - since we are not using any SIP phones.

Any assistance would be greatly appreciated.

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, after Submit and Apply Config, you must restart Asterisk.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
sip set debug on
according to whether the trunk is pjsip or chan_sip.
Make a failing call in, paste the Asterisk log (not the console output) for the call at .
As you are too new to post links, just post the last eight hex characters of the link here. Also post firewall make/model and any VoIP related settings. Confirm that hardware firewall has a public IP on its WAN interface. Confirm that VM is using bridged networking (local IP of PBX is in the same subnet as the LAN presented by the hardware firewall).

We have uploaded the log file, see upload under tapmetags42

For our inbound call test, we used one of our Sipstation: DID Verification numbers in an attempt to rule out any setup we might have influenced. This was all standard FreePBX install and SIPSTATION activation.

Again, the same number works fine on our OLD Asterisk, very strange.

OLD Asterisk 13.12.1
NEW Asterisk 16.20.0

Both the OLD and NEW servers share the same firewall and network.

We physically turn off one server before starting the other server.
They are never both started at the same time.
we use the same Internal IP address on both the OLD and NEW, since we did not want two Asterisk servers attempting to connect to the one (same) SIPSTATION account.

Sorry, I am having trouble navigating 6800+ lines of logs without the SIP trace as a guide.

I suspect that the contact rewrite on line 3707 is related to the trouble, but I can’t find an analogous rewrite of the media address in the SDP.

As requested previously, at the Asterisk command prompt type
pjsip set logger on
before making the test call. The log should now include the incoming INVITE and the 200 OK response given by Asterisk before it plays “you have reached …”


See log2 under ID tapmetags42

Thank you in advance

Line 79 shows audio requested to a private address, which obviously won’t work.

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. The pjsip-specific settings for the transport should have External IP Address and Local network left blank. If you change these, after Submit and Apply Config you must restart Asterisk.

Confirm that ESXi is using bridged networking (PBX LAN address is in the same subnet as the ESXi host).

Confirm that your hardware firewall has SIP ALG (or other SIP ‘helper’) turned off and allows traffic to the Bandwidth media server (

Confirm that the trunk settings has Rewrite Contact: No and RTP Symmetric: Yes.

If you still have trouble, please post:
Contents of /etc/asterisk/pjsip.transports.conf
Contents of /etc/asterisk/pjsip.transports_custom.conf or /etc/asterisk/pjsip.transports_custom_post.conf, if present
Make/model of hardware firewall and any VoIP-related settings.

The above resolved the issue. Thank you very much. I could have sworn I checked those settings, but clearly not.

I greatly appreciate your support.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.