No audio after answering

I have a freepbx installation back home with port 5060 forwarded so i can register phones outside of my network. I have no trunk set up so i don’t care if someone hacks into it. I set up a phone in Germany, it is a Mitel 6863, It registered like no ones business. But the issue is that there is no audio after the call is answered. There is a dialing sound, but there is no audio trading at all. I cannot hear the person on the phone that answered and they cannot hear anything I am saying. Same for the PBX its self. There is no noise when the voice mail answers or when the IVR answers. I have a Cisco SPA set up the same way and it works. Does anyone know why this is not working?

you need to open udp 10000-20000 (default)

Thanks, I will try this. But how come this phone isn’t working yet the other phone I have set up outside the LAN? is there something else I should check as well?

If you are having the problem entirely on your Internal LAN, there’s a different problem.

If a NAT device is in between any of your phones and the PBX, you need to forward the RTP UDP ports from 10000-20000 to your PBX from the firewall. If you don’t, the inbound audio has no place to go (the firewall blocks it) and you don’t get audio.

On the “outbound” leg, the port forward from 10000-20000 also makes sure that the RTP traffic gets back to the server from the outside.

No all the phones in my LAN are registered and work perfectly. Just this two phone here are doing it, so I know it isn’t a hardware failure. It makes the dailing noise and everything else just fine. I opened up ports 10000-20000 UDP and still nothing. I have a Cisco phone just like this one in the US set up and it works, even without the 10000-20000 open.

In the extension settings, set Nat to Yes.

In the Mitel Configuration menu? I’m not sure where I could find that. There does not seem to be anything in the Extension 1 or 2

In the PBX GUI, click on that extension, go to the advanced tab and set NAT to Yes. (Assuming you are using ChanSIP)

Phone registered but I still have the same problem. Now all the phones do not appear to work outside my Lan. There is one that answers and there is audio. How ever the phone does not pass audio back. For example the voice mail works and we can hear it. But it does not acknowledge pressing buttons since dtmf can’t pass through.

Maybe you need to verify that your dtmf mode is similarly on the phone side and the FreePBX side? SIP has multiple ways of conveying DTMF that might (or might not) be part of your problem.

That is just one of the things not working, DTMF is not the only thing that isn’t working. It is also voice traffic, the phone can hear the incoming voice data, but it does not send it. It goes no where.

Are these extensions ChanSIP or PJSIP?

Did you specify your local networks and external WAN address in your SIP settings?

1 Like

They are PJ SIP, I did register the phone to CHAN SIP to see if there was a change. I enabled NAT in chan sip as well and there was no effect. Still had the same issue. I’m not sure how to specify a WAN address. This set up was working perfectly fine just a week ago.

Settings > SIP Settings

1 Like

Would my Wan address be my public Ip?

Yes .

Go to Sip Setting>Local Networks change this setting to “”. match this to your networks. Using a “nn.nn.0.0/16”. Worked for me

1 Like

Perfect, it all works now thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.