Night mode incoming calls

Ok. This has me banging my head against my desk.
I have set up an inbound route to a time condition, to point to two different IVR’s depending on wether its office hours or out of hours.
Seems simple enough, right?
When it is out of hours however (and the button is lit indicating it is out of hours), the light goes out the second an incoming call comes in, and i get directed to my normal office hours IVR…
Please help :slight_smile:

Can you post a call trace? via pastebin

Also, can you describe your call flow?

Eg: Inbound Route > Time Condition > True = Day IVR, False = Night IVR.

The flow is:
Inbound route > Time Group > Time condition > Match: IVR VM > Non-Match: IVR Main Incoming (inverted BLF hint)

Just looking at the call trace now

This is not a call trace, please see the Wiki link I posted above and provide a pastebin link.

Also, can you please post a screenshot of that time group?

Struggling with “grep the asterisk” where do i get to the Asterisk console?

Ok found the Cli. no output returned

grep 1585567700.55562 /var/log/asterisk/full*

To confirm: You want every weekday between Monday through Friday between the hours of 1:00 PM to 1:30 PM it should go to Voicemail?

Not the Asterisk console. You need to run it from bash.

Excuse my ignorance - but how to i get to Bash?
At the moment the times are set up as a test - but yes, you are correct, the times i specify as a test i’d like to go to voicemail

OK got to bash! hang with me! i’ll get the logs to pastebin

I am not sure what you are expecting

You called at 11:28:20

The time group says If it’s between 12:27-12:30,mon-fri it should go to the True destination, but since it’s 11:28:20 it is going to the IVR.

Is it possible that the time on your system is off?

Did you set the time under Admin > System Admin > Time zone? Rebooted after setting?

Time might be off slightly.
i find it odd, as i am waiting for the light to flick over, once it does i call in? but like you have said, the logs show 11:28.
in my first image it shows 12:28! ive just seen it. time must be out! I’ll mess around and let you know :smiley:

As asked above, do you see the correct time under the timezone settings? have you rebooted your server after setting the correct time zone?

It was set to UTC i have changed it to the correct timezone and now works perfectly!! thank you for having a fresh set of eyes on this. It really helped :smiley:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.