Nextiva (pjsip/chansip) Trunk Configuration

siptrunk
configuration
freepbx
firewall
pjsip
Tags: #<Tag:0x00007f702a42e5e0> #<Tag:0x00007f702a42e388> #<Tag:0x00007f702a42e220> #<Tag:0x00007f702a42e0b8> #<Tag:0x00007f702a42de10>

(Freepbx Is Free) #1

I am having an issue with inbound and outbound calling on a brand new FreePBX 15.0.16.53 (Current Asterisk Version:16.9.0) installation.

  1. I have configured the FreePBX server and registered a phone at extension 101.
  2. I have created both a pjsip and chansip connection to my Nextiva trunk and they both say that they are registered (I know both are not needed).
  3. I created an inbound route directly to extension 101 on a registered phone.
  4. I created an outbound route using the pjsip trunk connection because I think that is what I should be using, (ideally?).

See ->

PJSIP

Nextiva_1/sip:myhost:5060 Nextiva_1 Registered
Nextiva/sip:myhost:5060 Nextiva Registered
Nextiva2/sip:myhost:5060 Nextiva2 Registered
Nextiva3/sip:myhost:5060 Nextiva3 Registered
Nextiva4/sip:myhost:5060 Nextiva4 Registered

Objects found: 5

SIP

Host dnsmgr Username Refresh State Reg.Time
sip:myhost:5060:5060 Y 123456789 3585 Registered Thu, 04 Jun 2020 18:55:53
1 SIP registrations.

CHANSIP

Name/username Host Dyn Forcerport Comedia ACL Port Status Description
Nextiva_ChanSIP/123456789 208.73.146.93 Yes Yes 5060 Unmonitored
Nextiva_ChanSIP2/123456789 208.73.146.93 Yes Yes 5060 OK (63 ms)
2 sip peers [Monitored: 1 online, 0 offline Unmonitored: 1 online, 0 offline]

I have a lot of trunk registered because I was trying to find the right configuration.

When I call my DID I get a message from Nextiva saying the wireless caller is not available. This is the same message I get when no SIP trunk is registered.

I have disabled the firewall on the FreePBX server. Also, we have a Sonicwall in front of the PBX that I increased the UDP timeouts on to 120. I installed Zoiper on a machine on the same LAN as FreePBX and can connect to the Nextiva SIP trunk and make and receive calls.

This is the format I am using for my registration string.
[Authentication Name]:[Authentication Key]@[Nextiva Host]/[Authentication Name]

Can anyone point me in the right direction to get these inbound and outbound calls functioning?


#2

Allow Asterisk to do NAT handling. Specify your public IP address in Asterisk SIP Settings. Disable SIP ALG / helper / “fix-up” on the Sonicwall so that it does not also try to handle the NAT transition. Those are the places I would start. After that, I would capture SIP traffic (perhaps at different points in the network) to look for problems.


(system) closed #3

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.