Newbie help moving SiP trunls to FreePBX


(Ken Curtis) #1

I am trying to test FreePBX as a replacement for our old Toshiba CIX. The Station side seems to be coming along great but now I want to test moving the SiP trunks and can not seem to the setting right. All I have from the provider and from the Toshiba is;
SiP Server: [A public IP]
Domain Name: [A pvt IP (192.168.x.x)]
user name: [base phone number]
password: [password]

I am not sure where I need to put the Domain Name. In the trunk sip settings for outbound I have added ‘fromdomain=192.168.x.x’ ‘host is the SiP server IP’, I added username and secret. incoming I put the secret. Is that right? I am getting
NOTICE[140607]: chan_sip.c:16030 sip_reg_timeout: -- Registration for '417xxxxxxx@192.168.x.x' timed out

Any help would be great to get me started
Thanks for helping this FP newbie


(Dave Burgess) #2

First, set up your trunk as a PJ-SIP trunk. This will help solve problems later.

Your SIP Server should be your ITSP SIP address. Many ITSPs use “IP Authentication” which allows you to set up a static IP address for your PBX’s external address. This is simple and secure. In your setup, put in the ITSP IP address in the remote address box. If you are going to use username/password registration, identify the connection as such and put in the username and password.

In the Advanced Settings, put in an entry for the “Permit” addresses that your ITSP will be sending calls from. This will vary from provider to provider. Their website should have more informaiton.

The Local Private address goes in the Advanced Settings -> SIP Settings. The local address should match the network for your phones in the LAN.

Get that going and let us know if you need anything else.


(Ken Curtis) #3

Never mind. I got it to work


(Ken Curtis) #4

Thanks