New to FreePBX


I am new to FreePBX. I just installed the below onto a dedicated machine.

PBXinaFlash version
FreePBX Version
Asterisk source version

I open FreePBX in my web browser and went straight to extensions. All I see is a pull down menu and a submit button. I choose SIP and hit submit, and I just get a blank screen. Can anyone advise on what the problem could be?


You should try a later version

Asterisk is at 1.8 or 10.?
FreePBX is at 2.9 or 2.10
PIAF at 2.0.6

Free PBX - Stable-1.815.210.58
Release Date-08/14/12

Where is the best place to find these versions?

In this general forum’s opinion at the top of this page under the download tab.

We are biased though and feel free to get the latest PIAF distro from them.

and installed FreePBX-1.815.210.58-i386-Full-1344631434 on win7 x64 system on VirtualBox. The initial install is freezing a few lines after I hit enter to install.

The last line (or where is freezes at) is:

NET: Registered protocol family 2

The only solution I tried was changing the adapter to “bridged adapter” with my NIC in the pull down menu.

What can I say, don’t use windoze over Virtualbox over an iso you are begging for trouble.

I downloaded and installed pbxinaflash20622-i386 on a dedicated machine. Apparently Aserisk and dahdi are unknown and n/a.

PIAF installed version
FreePBX version
Running Asterisk Version UNKNOWN
Asterisk source version
Zap/dahdi source version N/A
Operating system centos release 6.3
Kernel version 2.6.32-279.5.2.e16.i686 - 32 bit

I tried,

update-fixes, on the command line.

any insight?

Surely a question for the PIAF forum, don’t you think?

Like I said, I am new to this and I am not finding a solution over there. maybe someone else knows since these programs seem to install/run together? Thanks for the insight :wink:

So how about trying the FreePBX distribution, after all this is where you are asking questions :slight_smile:

I installed the FreePBX-1.815.210.58-i386-Full-1344631434 onto the dedicated machine now, I log on using the IP address and the extension settings page are still blank.

I read

set up the DNS addresses and Asterisk SIP settings with my external IP and network detected

Clear you cache, or use another browser, dollars to donuts it is a browser problem. Please don’t tell us you are still using IE :wink:

No I am using Chrome.

I’m sorry but I can’t help you, two different distro’s and your browser shows the same problem points to the browser. I don’t use Chrome, maybe someone else can help you.