New to FreePBX & need help setting up POTS lines

Hello I bought a Sangoma System 100 with a preinstalled A200 FXO card to replace my church’s failing nortel analog pbx. I have FreePBX with Asterisk Version: 13.22.0. After searching online I realized that I had to run setup-sangoma to get the card to show up. Now I cant seem to figure out how to configure the lines and extensions. The most comprehensive walk-through that I found on youtube only showed how to set up Chan-Sip extensions, I did that and am able to call between extensions but I’m guessing I will have to delete those and create DAHDI extensions.

I’m also seeing an error on the dashboard that says
Unable to write to /etc/wanpipe/global.conf
Please change permissions on /etc/wanpipe/global.conf or disable Sangoma DIGIUM mode

So basically I’m looking for guidance to set up the system with our 3 pots lines

Thank you

You can prob resolve this by running fwconsole chown. Once that’s fixed, you can configure your card in the GUI using the Dahdi Config module:

@lgaetz Thank you for your reply. I ran fwconsole chown as suggested but I’m still seeing the error

Does the file even exist? Try running

touch /etc/wanpipe/global.conf
fwconsole chown

Ok I ran the command and I no longer have the error.
I manage to set up a few extensions, two chan_sip and one dahdai. I can call between the two chan_sip exts and i can call externally from the chan_sip exts but i can’t call from the chan_sip ext to the dahdi ext or from the dahdi to external. Also the dahdi ext is not showing up in Extension Mapping.
I have no sip trunks should I be using chan_sip ext or dahdi ext

are you still with me @lgaetz

Call traces for failed calls to/from dahdi extensions might be a place to start:

If your A200 card has only FXO ports (which connect to POTS lines), then you cannot connect analog phones to it. Assuming that the church system uses standard analog phones that you want to reuse with FreePBX, you could connect them as dahdi extensions to the A200 card, but only if it came with FXS ports or you buy modules to add FXS ports.

Alternatively, you could buy an FXS gateway, which has FXS ports for the phones and connects to FreePBX over the LAN. Those extensions would be SIP.

1 Like

Thanks for your reply @Stewart1 My As200 card only has FXO ports. We don’t intent to reuse our analog phones since we bought S500 phones to go with the systems. based on your your response I deduce that DAHDI extensions are only for use with analog phones so I’m assuming that I should set up all my exts as chan_sip even though i have no SIP trunks and all calls will be coming in and go ing out through 4 POTS lines via the A200. I’m completely new to this so I’m trying to get some of the concepts straight. How would I setup the PBX to show the caller ID of incoming calls right now they show up as unknown

still here…

Can you get a call trace as mentioned?

Incoming calls and outgoing calls (to and from the PBX from and to the Outside World) all use Trunks. Your internal phones use Extensions and are managed completely separately.

So, having or not having a SIP trunk only if you are using SIP to get into or out of the system to the Outside World. Since you are going to use DAHDI for your external connections, your trunks will be DAHDI.

You internal extensions can use PJ-SIP or Chan-SIP. PJ-SIP is the recommended solution and now runs (by default) on port 5060. If you disable PJ-SIP it should (I think) switch to port 5060 from its default of 5160.

When you configure the extension, send it to the correct port to match the channel driver you want to use. I’m not saying you can’t disable PJ-SIP, but I’d recommend using it unless you absolutely can’t. For extensions, it works very well. There is still the occasional problem with SIP trunks (fewer every week) and PJ-SIP, but it should probably be your “go to” SIP channel driver anyway.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.