New Public IP, no external incoming calls


(United States) #1

Hello

I recently changed my public IP address and there seems to be an issue with the configuration now.

I originally had no calls, but I changed the asterisk SIP IP for NAT and that fixed the outgoing external audio, but the incoming audio is still an issue.

Where do I need to change the public IP address to restore this functionality?.

Any help would be great, I’m kinda in a hurry.

Thanks
-Trent


#2

Are you using IP auth or registration with your VSP?


(United States) #3

No, this should be all local issues.
my provider is UniTel, if that helps.


#4

That’s not a valid answer to my question, it requires an exclusive binary answer, either ‘IP auth’ or ‘Registration’.


(United States) #5

My bad, didn’t read it properly ha

I’m not using IP auth
Using pjsip Registration with a username and passcode with server name


#6

Does sngrep show your registrations being accepted?, if so does sngrep show any incoming INVITES after successful registration?


(United States) #7

Ok so I ran sngrep and I got some info that you asked for.

When I make an outgoing call, everything shows properly, and when I hang up I get completed.

Incoming calls add nothing and after like 1 second I just get the three hang up beeps

I also keep seeing this line come up every now and then labeled “newinvite1 @ 192.168.1.22” in sip FROM and in sip TO it’s my username @ sip unitelgroup com (can’t put the periods)


#8

Next step,

tcpdump -nn host 199.180.220.89

that is the IP of sip.unitelgroup.com

call out and call in, compare and contrast.


(United States) #9

Ok so, I get a bunch of text when calling out, but I get nothing when calling in. The calling out text looks normal and there are no errors


#10

start with having your firewall forwarding all traffic from 199.180.220.0/22 to your pbx’ internal ip.


(United States) #11

One more thing, I just noticed that every couple of seconds or so I get a line saying “Unsupported Method”

image
clipped so that you cannot see my username ofc


#12

Confirm that in Asterisk SIP Settings, External Address and Local Networks are correctly set. If you change these, in addition to Submit and Apply Config, you must restart Asterisk.

If you still have trouble, post make/model of router/firewall and any VoIP-related settings in it.


(United States) #13

My firewall is a PFSense firewall.
Everything was fine until the IP change. I know it’s not something in the firewall


(United States) #14

I have done this, and my incoming calls still aren’t coming through


#15

Then you presumable have a problem with your registrations, check with your provider.


#16

Maybe, but the best way to track this down is to look on the WAN side of the firewall. See
https://docs.netgate.com/pfsense/en/latest/diagnostics/packetcapture/

Start a capture and restart Asterisk to force a registration. The capture should show a REGISTER going out and a 200 OK from UniTel. The Contact header in the OK should contain your public IP address and port 5060 that pjsip is listening on. If not, track down where it went bad.

If the above is all good, start a capture and attempt an incoming call. You should see an INVITE request coming in. If not, it could be a provider issue, or an incorrect restriction you set on their portal.

If INVITEs are coming in, see whether it’s pfSense or the FreePBX firewall that’s blocking it.


(system) closed #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.