New outbound routes killing call transfer; what am I doing wrong?

Ok everyone, I have 7 asterisk boxes. All have had a single outbound route since they’ve been put into service, and have worked beautifully. I was recently tasked with interconnecting them so we can direct dial extensions. I set up IAX2 trunks between the boxes, and that went perfectly fine. I then set up outbound routes on each box such that if someone dialed an office code and extension, they would get that extension in the correlating office (ie, dialing 023113 would get extension 113 in office with code 023). The dial patter for the route to 023 mentioned above was 023|XXX.
This works great, but I have ran into the issue now that if someone attempts a transfer to another extension in their own office (ie, transferring from 101 to 100 via ##), the call is instantly dropped. This behavior happens in every single location, and if I remove all of the outbound routes, the problem goes away. I have to be doing something mind numbingly simple wrong, but for the life of me, I can’t find it. I’ve made sure the routes aren’t overlapping in dial plans, and I’ve also made sure the primary outbound route is still at the top of the list. Suggestions?


When I first started this, it seems there was caveat about beginning dial codes with a “0”, don’t know if that is still the case now, or how it applies in your situation, but it Might be something to look at. I’ve just always avoided using that.

I’ve actually tried it two different ways - with that code convention, and with a 2 digit code starting at 10 and going through 25 - I thought maybe the 2 digit code was interfering with the ‘##’ feature code.