New (Old) Backup/Restore Problems - CDR Database

Ok - Fully updated box - 6.12.65-30 - Needed to move to new hardware. All updates/patches applied - everything current to a new box with the exact same patch/update level.

Did a complete backup and restore and then tried to apply it - couldn’t apply with the same message as here:

and here:

So removed the CDR module and like above I was able to reload Asterisk - but from that point forward, even though I could get everything else working, I couldn’t re-enable the CDR Reports module.

And what’s weird is that looking at the install log when I tried to install the module, it was failing using the OLD password - even though it was right in /etc/freepbx.conf and /etc/asterisk/cdr_mysql.conf - although from the restore it was the old password in /etc/amportal.conf. But even fixing /etc/amportal.conf would still not let the CDR Reports module to install.

So I finally changed it to the old password in /etc/freepbx.conf, /etc/asterisk/cdr_mysql.conf, /etc/amportal.conf and then finally changed the freepbxuser password inside of MySQL and then I could install the CDR Reports module and all was happy.

Where is that Module Installer pulling the old password from? I even tried grepping the disc to see where that old password was installed, but I didn’t find anything.

So, the restore is not changing the MySQL password for freepbxuser, but it is storing it somewhere that the CDR Reports module is pulling from and choking on.



See Restore from FreePBX 12.0.76 server to a test server - CDR issues

Have a nice day!